AnsweredAssumed Answered

RX480 Issues: Poor performance + BEX64 error

Question asked by ludova on Jun 16, 2019
Latest reply on Jun 21, 2019 by elstaci

Generally, the graphics card seems ok. But there are issues that make me think something is wrong and it is not performing at a proper level.

Example: When I open Photoshop, I get a warning message (see img Photoshop-1).

 

The driver is updated automatically through windows and everything suggests it is functioning fine. Still, I figured I'd check it out and tried to download your current software Adrenalin. Yet when I tried to run it, the install stops and says it has to close:

 

  Problem Event Name:    BEX64
  Application Name:    RadeonInstaller.exe software

 

This happened with the full software and the minimalized detection software. I tried downloading again.. but same thing.

 

Furthermore, my speakers end up being really very faint even at max volume. This may or may not be connected, but since the audio is an AMD High Definition Audio Device I figured the driver detection tool may look at that as well.

 

When I built my computer I took great care ensuring everything was going to be compatible... right down to the power supply and ensuring a roomy case for proper cooling. I knew I would need a stronger card for some 3D applications I need to run (3Ds Max also runs a little buggy especially when rendering) and even Adobe AI or ID sometimes tend  to lag in performance. So it isn`t so much that something is terribly wrong... it is just that I don`t feel I`m getting any special performance. In fact, on many levels it is no better than the graphics card I replaced which was 10 years old (also AMD although can`t recall exactly which - long expired.)

 


Here are my specs:

 

Operating System: Windows 7 Ultimate 64-bit SP1
CPU: Intel Core i5 6500 @ 3.20GHz    30 °C
    Skylake 14nm Technology
RAM: 16.0GB Dual-Channel Unknown @ 1065MHz (15-15-15-36)
Motherboard: ASRock H170A-X1/3.1 (CPUSocket)    37 °C
Graphics: S24D360 (1920x1080@59Hz)
    ATI Radeon RX 480 Graphics (ASUStek Computer Inc)
Storage:  931GB Western Digital WDC WD10EZEX-08WN4A0 ATA Device (SATA )    32 °C
    1862GB Western Digital WD My Passport 0830 USB Device (USB (SATA) )    32 °C
Optical Drives: No optical disk drives detected
Audio: AMD High Definition Audio Device

 


I`ve also attached a couple of other images in case I forgot to mention some details.

 

Thanks in advance to all who take the time to look at this.

 


PS: Yes, I made sure Win updates are current before retrying everything.

Outcomes