AnsweredAssumed Answered

Threadripper 1950X Clockspeed

Question asked by jppm on May 30, 2019
Latest reply on Jun 24, 2019 by misterj

Hello,

 

I am new around here and also new at AMD processors. Actually I changed everything in my setup moving from Apple iMac (15 years apple user) and get back to build a new PC from the scratch. A few months of research and investigation made me comfortable about which hardware to choose and also with the actual PC world, because everything is so different in the good way.

 

 

My Build:

AMD Ryzen Threadripper 1950x

Cooler Master Masterliquid ML360 TR4

ASUS ROG Strix x399 E-Gaming

Hyper X Predator DD4 3000Mhz CL15 - 64GB (4x16GB)

ASUS ROG Strix RTX 2080 TI 11GB 

Samsung 970 EVO PLUS - 1TB

Western Digital Balck 2TB

Corsair HX1200 80Plus Platinum Modular - 1200W

NZXT H700

 

 

I work as Product Designer and I use the Cinema 4D for 3D modelling and rendering. Now and with this new build I am ready to start playing around with GPU rendering, but for now I only need CPU rendering. So I used to buy i7's with turboboost and hyperthreading what is extremely useful for my 3D renderings. However with my 1950x that is 3.4 - 4.0Ghz I only get 3.7Ghz "stuck" (after installed driver). For example, with my last i7 Skylake that was 4.0 - 4.2Ghz it managed his clock speed for his own need, if I was rendering it will boost to 4.2Ghz and when it finished it will "drop" the clock speed to 4.0ghz (or less I am no sure). I thought the Threadrippers will work in the same way managing the clock speed according to his need, but now I am not sure about that. Before the driver installation the clock speed was constantly moving up and down from 2.2Ghz to 3.7Ghz, with nothing running in background. Concluding what I need to know is if there are a possibility to make it work 3.4 to 4.0Ghz automatically. 

 

By the way I tried to use Ryzen Master and everything was alright until I tried to "force" him to work at 4.0Ghz to run a Cinebench but the RM just crashed my PC. I rebooted and when I opened the RM again it automatically crashed my entire PC. I uninstalled and installed it without made any change and it crashed my PC again. So the RM is not a solution for me.

 

I tried to find a topic about this subject but I didn't found it, I hope that I didn't missed it.

Sorry if this is a long post but I thought that was important to you understand my needs and everything else.

 

Thank you for your attention,

João Mendes.

Outcomes