AnsweredAssumed Answered

Prorender does not work with recent 2.8 builds

Question asked by alicecrawford on May 17, 2019
Latest reply on Aug 14, 2019 by henriquelj

Hi, I've found an issue with the 4 Apr 2019 build of AMD Prorender with the current Blender 2.8 beta builds after 16 May 2019.

 

This change has been made to the Blender API, breaking Prorender (and potentially other renderers):

https://developer.blender.org/rB2ee762344f8742618804e869536e3efee6ab0bd0#change-SGUusqczrUIQ

 

 

With the stock Prorender when trying to use a very recent Blender 2.8 build and enabling the addon I'm getting this traceback:

File "/Applications/blender.app/Contents/Resources/2.80/scripts/modules/addon_utils.py", line 384, in enable mod.register()
File "/Users/[redacted]/Library/Application Support/Blender/2.80/scripts/addons/rprblender/__init__.py", line 111, in register() bpy.utils.register_class(RPREngine)
ValueError: expected RenderEngine, RPREngine class "view_update" function to have 3 args, found 2

I've traced it down to that change, linked above; Blender added the view_update and view_draw methods to take a depsgraph object in addition to a context object.

Tonight when I get home from work I'm going to poke around with the python portion of my installation, to see if I can get it working; but I think that adding the argument for depsgraph to these functions and adding the called functions to take that depsgraph object and use it instead of the context object will get it working again.  I'll update this post with my progress.

Outcomes