AnsweredAssumed Answered

Major Issues w/ XFX RX580 GTS XXX Edition (8GB)

Question asked by thill1239 on May 14, 2019
Latest reply on Jul 28, 2019 by jhasan86

Hi there, 

 

I recently built my first PC and the build went great (initially)... Here is my setup: 

 

Thermaltake Core V21 Case (200mm case fan on front, intake)

2x Corsair 140mm Case Fans (exhaust)

Seasonic 80+GOLD 550w PSU

ASRock B365M Phantom Gaming 4 MicroATX mobo (LGA 1151 socket)

Intel Core-i5 9400f w/ Cooler Master Hyper 212 Evo CPU Cooler (Arctic MX-4 Thermal Paste)

XFX Radeon RX 580 GTS XXX Edition 1386Mhz OC+, 8GB GDDR5

Corsair Vengeance LPX 16GB (2x8GB) DDR4 DRAM 2666MHz

2 x Crucial 256GB SSDs connected via SATA 6GB/s

2 x WD 5400rpm HDDs connected via SATA 6GB/s

Hooked up to my Samsung QLED 55" 4K TV (Q6F model)

Running Win 10 Education (OS build 17763.475)

 

One of the main reasons I built this PC was to play my favorite game, Cities: Skylines. I had been playing on my MacBook Pro but it just wasn't a great experience. Anyways, after I first built the PC I was playing the game at 1920x1080 no problem. Highest detail on everything and it loaded perfectly and looked awesome. However, I noticed that my Windows display settings were set to 1920x1080 and since my TV and graphics card support 4K, I obviously wanted that resolution. I had the hardest time getting it to change, and eventually figured out it was a cable issue. The "4K" cable I purchased on Amazon wasn't true 18Gbps 4K, so it didn't work. Fast forward with the new cable and Windows loaded into 3840 x 2160 automatically and looks great.

 

Now the problem is that whenever I load Cities: Skylines, it will flicker on the loading screen and then when the game loads the black screen flickering gets so bad that I just have to Alt+F4 the program and close it entirely or I can't do anything at all. I should mention that I did set the game to 3840x2160 resolution (since it had that option, I figured why not) and this is when I first saw the issue. I assumed that taking it back down to 1920x1080 would fix it, but this is not the case. The exact same thing happens no matter how low I take the resolution. Also good to note that when the flickering occurs, I am losing both audio and video to the TV. 

 

I've done a ton of testing and found a couple weird things - audio and video seem to cut out when trying to load / play the game and when trying to watch any Netflix program via the Win10 Netflix app. I thought maybe it's just an issue with video / games, as just browsing and doing other things on the PC works great. But I decided to try watching Netflix through Chrome and it worked perfectly! No black screen, no audio cut out (or audio delay), anything. Tried watching a video on YouTube as well and it worked perfectly. 

 

I have looked on every forum and spent hours researching this issue and I am at a loss. I bought the graphics card on Amazon and the last day to return it is May 20th, so I am trying to solve this ASAP or see if I should just forget it and return it.

 

Have tried adjusting power / fan / OC settings in Wattman, unplugging and plugging in HDMI cable, enabling / disabling FreeSync on the TV and on the GC, enabling / disabling HDMI link assurance, and lots of other things too. Updating all drivers, reinstalling Windows, etc. No luck with anything yet. 

 

Sorry for the long post but this has been a huge pain for me and any help or advice is much appreciated!! 

Outcomes