transfattyacidtrip

Applying AMD drivers cause black-screen, corrupt Windows boot record

Discussion created by transfattyacidtrip on Apr 27, 2019
Latest reply on May 4, 2019 by hardcoregames™

Problem: Applying any number of AMD Radeon drivers (Adrenaline 19.4.1, 19.4.2, 19.4.3) appear to corrupt and crash Windows 10, causing black-screen and PC to become unresponsive (apparent boot record corruption).

 

*****

 

How to reliably reproduce the problem (NOTE: I worked with Microsoft Support/Tier 2 to figure out root-cause/how to reproduce - they said (without hesitation) I had to come to AMD for a solution:


- Use Windows 10 1803 (OS Build 17134.1) ISO image on USB to format C drive (boot drive, 256 GB SSD) and then load Windows 10 to it.
- Microsoft Support/Tier 2 verified I now had a clean corrupt-free load of Windows 10 1803.
- Display Adapter is set to "Microsoft Basic Display Adapter."
- Now boot to Normal Mode, Connect to internet, NO issues, you can browse the internet and execute apps WITHOUT issues. NO black screens.
- Now disconnect from internet, load latest AMD Radeon drivers from a USB (drivers acquired from "Radeon Software Adrenalin 2019 Edition 19.4.1, 19.4.2, 19.4.3").
- Now use Device Manager, expand "Display adapters"), highlight "Microsoft Basic Display Adapter", right-click, choose "Update driver", choose "Search Local PC only"
(i.e., pull only from locally loaded AMD drivers). Drivers start to load and then computer goes to BLACK screen and unresponsive.
- A subsequent reboot yields a Windows logo, and then black-screen. Going into Advanced Options shows that boot record has been corrupted.
- Boot back to safe-mode, downgrade display adapter driver to "Microsoft Basic Display Adapter", boot to Normal Mode and even connect to internet, everything is fine again, NO issues, NO black screen.
- I am also unable to upgrade up to Windows 1809. Same black-screen, Microsoft Support/Tier 2 believes that it is issue with AMD drivers rolled up into their KB updates.

 

*****

 

Machine H/W and S/W Configuration:

 

Dell Dimension XPS 8500

 

Intel Core i7-3770 CPU @ 3.40GHz
Intel Core i7-3770 CPU @ 3.40GHz; Processor ID: 306A9
Processor Core Count: 4
Processor L1 Cache: 256 Kb
Processor L2 Cache: 1024 Kb
Processor L3 Cache: 8192 Kb

 

Installed memory (RAM): 16.0 GB

 

System Type: 64-bit Operating System, x64-based processor

 

AMD Radeon HD 7800 Series (7870); specifically, Radeon HD 7870 GHz Edition
from: https://devicehunt.com/search/type/pci/vendor/any/device/6818
type: PCI
device id: 6818
PCI 1002 Advanced Micro Devices, Inc. [AMD/ATI] 6818 Pitcairn XT [Radeon HD 7870 GHz Edition]
from examining the physical graphics card:
- manufacturer appears to be: ATI Technologies ULC.
- P/N: 7120700000G(226A1XX)

SATA Information:

SATA0/Port0: ST2000DM001-1CH164 (2000.3GB)

MSATA1/Port1: SAMSUNG SSD PM830 mSATA 25 (256.0 GB)

 

From "diskpart" command:
Disk 1, Volume 3 (drive letter C, SSD drive) is the boot drive.
Disk 0, Volume 1 (drive letter D, 2 Tb SATA drive).

 

From Aptio Setup Utility:
BIOS Revision: A09
BIOS Build Date: 09/05/2012
Secure Boot: Disabled (I've also tried it set to "Enabled")
Boot Mode: UEFI (I've also tried it set to "Legacy")

 

*****

 

Key error messages from bottom of AMD "installer.log":

PMJobExecuter::executer ======= Starting installation of: AMD Display Driver =======

WrapDIFx::[26-04-2019 04:40:46] Turn ON DGPU fail
PMJobExecuter::executer::[26-04-2019 04:40:46] Install Sub-Packages first for AMD Display Driver

PackageManager::[26-04-2019 04:40:46] ExeInstaller::executeProc initiating installation of C:\AMD\Win10-64Bit-Radeon-Software-Adrenalin-2019-Edition-19.4.3-Apr22\Packages\Apps\VulkanRT64\VulkanRT\VulkanRT.exe.
PackageManager::[26-04-2019 04:40:47] ExeInstaller::executeProc exit code of process returned 0.
PMJobExecuter::executer::[26-04-2019 04:40:47] : Subpakcage installed: VulkanRT

[ERROR] - ERROR_DRIVER_PACKAGE_NOT_IN_STORE::[0000005A288F8300] There does not exist an INF file in the driver store that corresponds to the INF file specified by DriverPackageInfPath.
UnCompressRSInstallExe::[26-04-2019 04:40:47] Executing ccc2_install.exe
UnCompressRSInstallExe::[26-04-2019 04:40:47] C:\AMD\WIN10-~1.3-A\Packages\Drivers\Display\WT6A_INF\B341390\ccc2_install.exe /NCRC /S -EXTRACTONLY=YES /D=C:\Users\Dad\AppData\Local\Temp\AMDRSInstaller
UnCompressRSInstallExe::[26-04-2019 04:40:48] Create process success
UnCompressRSInstallExe::[26-04-2019 04:41:01] ccc2_install.exe process completed
WrapDIFx::[26-04-2019 04:41:11] DiInstallDriver is Successful
WrapDIFx::[26-04-2019 04:41:11] AdapterPowerChangeRequestinPX call is failed
PMJobExecuter::executer======= AMD Display Driver installed successfully!!! =======

Outcomes