AnsweredAssumed Answered

Warranty Return Approval: How Long Does This Take??

Question asked by samket on Apr 27, 2019

Warranty Service Request Opened on 14 April, outlining the issue - namely cpu not posting, new build (details below)

I got a vague reply on the 15th suggesting the issue was due to the mobo bios not being updated - although I had made it clear in the original request that this had been done by supplier. I sent over cpu invoice/receipt as requested. But since then, nothing...

I've chased up via email 3 times and got the auto responses. And I've called AMD tech support 01276 932318 midday on Thurs 25th who said they would get onto it, but still nothing.

It's been 2 weeks ago. I personally think that's unacceptable. But anyway, here's the details, * components purchased from Ebuyer.


* 1 x MSI AMD Ryzen AM4 X370 GAMING PLUS (requesting you update BIOS prior to dispatch)
* 1 x AMD RYZEN 3 2200G Processor
* 2 x Adata Premier DDR4 2666 UDIMM
* 1 x Toshiba TR200 240GB 2.5

(powered by G7 Power Extreme 680w PSU)

But it didn't post, cpu debug led on.


So I updated PSU to Aerocool Integrator 400W - Still NO POST, cpu debug led, on min. config


Next, I RMA'd the CPU to Ebuyer. CPU was FAULTY and was replaced. But when I get it back, still NO POST, cpu debug led, on min. config


Next I RMA'd the board to Ebuyer. NOTE: The board didn't post so they updated the BIOS. But when I get it back, still NO POST, cpu debug led, on min. config


So we go through another RMA for the board, after sending pics of the CPU. Ebuyer then updated the BIOS (again!), testing with ryzen 7 cpu and return it to me. But still NO POST, cpu debug led, on min. config


So then I buy a different MOBO (ASRock B450 PRO4, bios P1.50) thinking its a compatibility issue with the Msi X370 and Ryzen 3 2200g - there are some cases online of people facing similar problems. But NO POST on min. config


Next, I try with different DDR4 (Vengeance LPX 2400, 2x8gb). But yet again NO POST, min. config.


So, we can assume it's not the boards, it's not the RAM, it's not the psu. So it has to be another CPU that's faulty.


Needless to say, I'd appreciate it if someone to get on to this before I die of old age.


Side note: Ive built 3 pcs from scratch in the past 5 years and never had an issue with any.


Thank you