AnsweredAssumed Answered

Can´t install the new Blender Version 1.4 , need the old Version 1.2.0

Question asked by mrackwitz2019 on Apr 26, 2019
Latest reply on Apr 26, 2019 by pokester

Can´t install the new Blender Version 1.4 , need the old Version 1.2.0 

Need a old installation msi for Blender 

where can this downloading ?

Thanks for help

Outcomes