AnsweredAssumed Answered

RPR 2.0.52 Viewport Noise split on macOS with AMD dGPU + AMD eGPU

Question asked by gelert on Apr 12, 2019

In macOS with GL_Interop = True (as per the default setting) it is still impossible to disable an internal dGPU while using an eGPU as the primary display device and putting a MBP 15 inch into Clamshell Mode.

 

macOS will correctly report that the primary display GPU is the eGPU.

 

However Blender 2.8 and RPR 2.0.52 will not allow you to disable the dGPU (Radeon Pro 560) for Preview Rendering.

 

Instead forcing you to use both the 560 and WX 9100 for viewport rendering.

 

This has the nasty effect of not only slowing down the preview rendering (because the 560 drags down the WX 9100) but also introduces a nasty noise to the viewport render (see left ¼ of the screenshot below).

 

As a test: Final Render with the 560 dGPU + WX 9100 enabled will take longer than just the WX 9100 enabled.

 

If I set the config.py file to GL_Interop = False to allow the WX 9100 to take full control RPR becomes much more unstable.

 

The noise split across two GPUs in preview mode is the primary issue here.

 

In GL_Interop = True mode everything is very stable. I hope that in the future the other mode can also become stable so that multiple eGPUs can be used to speed up viewport preview rendering as they currently do for Final Render.

 

Outcomes