AnsweredAssumed Answered

PC turns on, but no post

Question asked by eleitas on Apr 12, 2019
Latest reply on Apr 16, 2019 by prodoctor1987

Hi, I recently purchased a Ryzen 2700x to go inside the new PC that I am building. After getting everything put together, I've found that the PC turns on just fine, including all lights/fans even on the GPU, but I get no POST at all. I also have a motherboard speaker installed that gives me no beeps when the PC is started. After some testing, I think I've ruled out my RAM sticks as they work in another system. I think I've also ruled out my GPU as I've tried more than one to no avail. I'm on my second motherboard and from what I can tell it isn't the issue. I've also tried resetting CMOS by jumping and removing the battery.

 

At this point I think I've narrowed it down to either the PSU or the CPU. For the PSU, I know about the paper clip test so I know a way to test that. I'm just kind of stuck on the CPU. Aside from sticking it inside a different PC to see if it works (I only have LGA sockets to work with besides this current B450 board) is there anything I can test or try to see if the CPU is what's causing me troubles? I know of breadboarding, but I'm worried about breaking my motherboard and I unsure of how it would tell if the CPU is not working.

 

Any advice or insight would be greatly appreciated, I'm really hoping I don't have to RMA the chip as I don't think I have a way to package it safely.

 

  • CPU: Ryzen 7 2700x
  • GPU: GTX 1660 Ti
  • RAM: 16gb G.Skill Trident Z 3200mhz
  • MB: MSI B450 Tomahawk
  • PSU: EVGA SuperNOVA G2 750W 80+ Gold
  • Case: Fractal Design Meshify C White - TG

Outcomes