sorrywerefull

VR-Tek WVR1 Virtual Reality Headset Doesn't Work With Adrenaline Versions Past 18.1.1?

Discussion created by sorrywerefull on Apr 11, 2019
Latest reply on May 29, 2019 by shasta

First of all, yeah, I've got a really uncommon headset that barely anybody seems to know about or have. I got it because it's cheap and I wanted something to play No Man's Sky VR with when it comes out. So the cool thing is that the headset works great! The bad thing is that it only works so long as my Adrenaline version is no higher than 18.1.1. Why? I don't know, and that's what I came here to maybe find out, and I kind of hope to get AMDs attention on the matter, because people with Nvidia cards don't seem to have the problem I'm having on this headset (I know this because I have looked around all over the internet for answers, and have dissected every comment on the slickdeals website regarding the headset for clues). 

 

So here are the details:

The problem that occurs is that on any Adrenaline version above 18.1.1, SteamVR DOES start with no errors, but the headset itself only gets pushed the first frame of the game when it starts and no further frames get loaded. This results in my seeing a static image of the room you start out in in SteamVR home in the right eye. If I show the headset mirror, I can see that the mirror itself works properly; even the tracking works in the mirror. I can move the headset around while looking at the mirror on my monitor and the game responds just fine on the mirror, just not in the headset. Moving back down to 18.1.1 version of Adrenaline fixes the problem and I can use the headset just fine, but then I can't play Star Wars Battlefront 2 (unpopular opinion but, I looove that game, it's my favorite online game). 

 

As a formality and to help anybody who may know a fix, here are my hardware specs:

Headset: VR-Tek WVR1 

Monitor: Acer G276HL

GPU: AMD RX 580

CPU: Intel I5 4690

RAM: 24 GB Dual-Channel DDR3 (can't remember the brand, don't feel like opening my case)

Motherboard: Gigabyte Technology Co. Ltd. Z97X-SLI-CF (SOCKET 0)

Storage: 1863 GB Seagate ST2000DM006-2DM164(SATA)

931GB Seagate ST1000DM003-1ER162 (SATA)
111GB INTEL SSDSC2CW120A (SATA (SSD))

Sound: Presonus AudioBox USB 96

 

Also, some extra info. I tried this Trinus PSVR trick that other people who have used the VR-Tek headset have tried and said worked, and that didn't work either. Supposedly, installing Trinus's VR drivers to SteamVR made the headset work... Normally, you would install Direct-Tek's Holoview drivers, and those are what allow the computer and the headset to communicate. I'm assuming that the drivers Trinus offers must be compatible with the headset, but they probably would only work right if I had Adrenaline ver. 18.1.1, seeing as the headset's normal drivers don't work on any version above that. Another side note, the headset itself works as a monitor just fine on any Adrenaline version, it just won't play VR games above Adrenaline 18.1.1 because of the frame issue. 

 

I tried contacting Direct-Tek about the issue, and they never responded. Seeing as it is a compatibility thing between the the headset's drivers and AMD, I figured maybe talking about it here could possibly yield some desirable results, although I'm not going to get my hopes up on it; I'm thinking a lot of people are going to say something like "just return the headset, buy a Vive," to which I'm going to say right now: the Vive isn't an option for me at the moment, and neither is the Oculus. If you are going to make that sort of comment, don't waste your time on it, because I won't take it into consideration or give it any attention. 

 

Regards,

-The Janitor

Outcomes