AnsweredAssumed Answered

Batch render Issue in Maya OSX

Question asked by edubais on Apr 1, 2019
Latest reply on Apr 2, 2019 by david_s

So I was doing some tests to start using ProRender in maya on my Macbook pro, made a simple scene with RPRPhysicalLight1, and UberShaders, to test refractions and reflections on indoor scene. I Rendered with Render Panel and with "Render Sequence" and everything runs pretty well. 

 

 

 

But when when I run the "batchRender" this was the result:

 

A very low sample image with no trace depht.

 

Looking at the console I notice that after some processes the batch render uses a fireRender command to perform the render. So I run this command "fireRender -batch  -layer defaultRenderLayer" on the script editor and it works, but this was the result:

All the samples are there but still did not recognize the trace depth setup.

So I can reach the conclusion that Batch render and fireRender are not communicating the right way.

Did anyone had this problem?

 

if render can be run over mel script, What should be the right command line there?

 

I am using RPR 2.5 because the 2.6 build crash when I hit render.

 

Also I want to add for the record that batch render is way way faster than render sequence. So there must be something of CPU or GPU that Render sequence is not taking advantage of.

 

Thanks.

Edu

Outcomes