AnsweredAssumed Answered

RX 590 Black Screen After Driver Install, Why?

Question asked by exare on Mar 28, 2019
Latest reply on Mar 28, 2019 by exare

Hi all, first time visiting and I'm desperate.

 

My background:
I build many PCs a year for friends/family. I fix their PCs whenever they have a problem whether it be a 10 year old machine, a brand new AMD/Intel/Nvidia build, or something g I made myself. This is the first time I've run into this.

 

I'll be as thorough as I can be.

 

I purchased an RX 590 Sapphire Nitro+ to install in a mATX build and I can't for the life of me get the drivers to install.

 

Specs:
Mobo: MSI B450M-PRO VDH
CPU: R5 2600 w/ stock cooler
GPU: RX 590 Sapphire Nitro+
RAM: 8GB Patriot Viper 4 3000Mhz @2133 (motherboard won't run RAM with AXMP or with manual OC)
PSU: Corsair RM550X
SSD: Team Group Delta Force RGB 500GB
Case: Masterbox Q300L
Fans: Silverstone PWM Fan Hub with 5x Aigo Purple Fans
OS: Win10 Home 64-Bit
Monitor: 1440p Korean Monitor from 2013 @64Hz

 

Symptoms:
While installing AMD drivers - either through auto detect software or manually downloaded drivers - the install gets roughly halfway through until I hear the normal Windows device disconnect noise through my headset (plugged into rear io) but I do not hear it reconnect, the screen goes black, the fans on the card stop spinning, and then the picture never returns. Waited 15 minutes and nothing, monitor reports "No signal".

 

I then must restart the PC several times to enter safe mode because once the Windows splash screen finishes and Windows tries to load, the GPU turns off (fans stop spinning) and I have a black screen. I CAN see my BIOS just fine. I'm assuming the drivers are not functioning properly, that is why Windows loads just fine through the 590 with no drivers installed and when in safe mode. When drivers are installed and Windows tries to load them after splash screen, no Windows desktop can be seen and the GPU shuts off (at least, the fans stop spinning and it gets cold).

 

I have not found a smoking gun in Windows Event Log.

 

I upgraded this PC from a 2200G to a 2600 prior to installing the new GPU. It works fine with a GTX 970 installed.

 

Things I have tried:
-Install every major, non-optional driver release for the 590 since it went on sale in November including 18.11. 1, 18.12.2, 19.1.1, and 19.3.3
-Use DDU and AMD Cleaner software in safe mode between each install
-Updated BIOS to latest version
-Reinstalled Windows
-Tried installing default Windows Update drivers then installing AMD driver package
-Tried plugging in the old 970 Nvidia GPU to install AMD drivers (it won't let me)
-Enabled WHQL in BIOS
-Tried installing drivers first on a fresh install of Windows 10 with network cable unplugged and network devices disabled through Device Manager
-Flipping BIOS switch on 590 then trying to install drivers on fresh Windows install
-Disable Windows Firewall and Windows Defender

 

Things I've yet to try:
-A different monitor
-Display Port instead of HDMI
-Figuring out how to force 60Hz
-Update Chipset Driver from MSI website
-Disable Secure Boot
-Reseat RAM or try w/ single stick
->driver installed>safe mode>Windows key + R>msconfig>Boot>Base video (low resolution with the driver being active) (doubt this will work since GPU doesn't seem to be powered on.
-Using a different PSU

 

This is my second RX 590 Sapphire Nitro+ in 2 days. I RMAd the first in and Newegg sent me a replacement overnight. The problem persists between both GPUs. Either I received 2 lemons (unlikely) or something else is amiss that is preventing the driver install. I believe I have this narrowed down to the time of driver install when the device disconnects then is supposed to reconnect, it doesn't reconnect and the system/driver install hangs.

 

I will update this if I remember anything else I've tried. Tonight I plan on trying a few of the things above, including plugging the GPU in with a different PSU.

 

Please help. Thank you!

Outcomes