artisresistance8

Driver Updates Post 18.3.1 Break Windows 10 - No USB or Network After Reboot

Discussion created by artisresistance8 on Mar 23, 2019

I just upgraded to a RX580 and cannot use drivers newer than 18.3.1 (the ones that came on the installation CD).  If I install drivers newer than that, after installation and rebooting the system, once Windows loads to the login screen I've lost all USB ports and network adapters.  Therefore, I cannot use keyboard\mouse (Logitech MK700) and get to the desktop.  I know the network isn't working because it shows the disconnected icon in the bottom-right, with the system working it'll connect while at the login screen.  Windows is NOT frozen at this point - the clock changes if I leave it at this screen.  If I turn off my login password it will load the desktop as expected, but still no input devices or network are working.

 

This is happening with a fresh install of Windows 10 64-bit.  I've tried many troubleshooting steps and everything is a dead end.  Troubleshooting is a slow process as the only way to recover from the problem is to restore from a system image or reinstall Windows (System Restore has been unreliable).  The keyboard works in BIOS and both keyboard & mouse work in the recovery environment.  The issue persists in Safe Mode and happens no matter how I install the newer drivers (clean install, network on\off, etc.).

 

Have tried updating all possible drivers (chipset, audio, monitor, mouse & keyboard, USB controllers, network adapters) and made sure Windows is up-to-date.  

 

It seems like the AMD drivers post March 2018 are creating some sort of conflict with other drivers after the install + reboot.  It does not seem to be a hardware problem since everything is working fine with 18.3.1.  I do see the USB, Network, and Sound devices sharing IRQ 16-17 but am not convinced that's an actual problem.  The GPU is using an odd IRQ, 4294967294, but is that normal?

 

Describe your system:

  • XFX RX580 8GB (RX-580P8D)
  • Desktop
  • Windows 10 64-bit
  • Adrenalin 18.3.1
  • Dell SE2717H/HX, HDMI, 1920x1080 @ 60Hz
  • XVGA P55 LE E653, BIOS A74
  • Intel i5 750 @ 2.67Ghz
  • Kingwin 700W Power Supply
  • 16GB RAM

 

EDIT: I've narrowed this down to the AMD "Pci Bus" driver that is installed with the GPU drivers.  If I install 19.3.3, rollback the PCI Bus driver to the MS one, and then reboot - I can get back into Windows and everything is working.  Problem is, every time I do this the OS automatically re-installs the AMD Pci Bus driver, meaning I would have to repeat the rollback step every time I reboot.  Has anyone seen this before?

Outcomes