aaraujo

AMD X470 USB 3.1 Gen2 issues

Discussion created by aaraujo on Mar 18, 2019
Latest reply on Jun 20, 2019 by ranmacanada

I am using a StarTech.com USB312SAT3CB SATA III to USB 3.1 Gen2 (10 Mbps) adapter
https://www.startech.com/HDD/Adapter...e~USB312SAT3CB
with a Samsung SSD 850 PRO
https://www.samsung.com/semiconducto...nsumer/850pro/

The motherboards is an ASUS ROG STRIX X470-I GAMING. I am having issues getting one of the USB 3.1 red ports at the back to work with this SATA to USB 3.1 Gen2 adapter. One of the USB 3.1 red ports works perfectly fine. However the other USB 3.1 red port detects the device at USB 3.1, but the drive disappears a few seconds afterwards, and can never be used with this port. The operating system is Windows 10 64 bit. I have tried the same USB 3.1 port under Linux but the drive never appears. Again the other of the two USB 3.1 red ports works fine under Linux.

 

I am also having VERY VERY SLOW speed transfers between the same USB 3.1 red ports at the back, and a LG G6 smartphone. I am using an Anker USB-A to USB-C 3.1 Gen2 certified cable. The same SLOW speeds are observed while using the USB 3.0 ports at the front. I get normal speeds while using the blue USB 3.0 ports at the back. The cable is this one
https://www.anker.com/products/varia...e-3ft/A8465011

 

I already RMAed the motherboard twice. The first time I received the same motherboard after 2.5 months. Only to find that the same issues remained. The second time, after waiting another 3 months, I received a brand new motherboard. Same problem!

 

After searching the web I found this relevant information:

 

AMD "Zen" Processor Integrated Chipset Has USB 3.1 Issues, Could Escalate Costs | TechPowerUp 

 

Quote from this ASUS ROG Strix B450-I Gaming Motherboard review:

https://www.kitguru.net/components/m...ard-review/10/

 

USB 3.0 performance was as expected while USB 3.1 performance experienced numerous performance and compatibility issues similar to those we observed with the ASRock X470 Gaming-ITX/ac motherboard.

Effectively, there’s a bug where connected USB 3.1 devices disconnect during heavy and sustained loading. We experienced this bug using a USB 3.1 ASM1352R RAID box and ASM1351 USB 3.1 to SATA III device with the OCZ Trio 150 480GB SSD.

The only way we were able to complete an ATTO run from start to finish without interruption while using USB 3.1 was with the ASM1351 USB 3.1 to SATA III device and a Transcend SSD370S 512GB SSD.

Given the MSI B450 Tomahawk successfully completed USB 3.1 testing using the B450 chipset controller we can only assume this is a motherboard specific problem. It’s difficult to say which USB 3.1 component causes the problem, as it is unlikely to be the controller.

We expect this ASUS motherboard and the ASRock X470 Gaming-ITX/ac must have a similarity somewhere as both failed in similar ways when using USB 3.1, our best educated guess at this stage is that it is potentially a compatibility issue with USB 3.1 redriver chip.

 

Then I tried a different motherboard, this time an ASUS ROG STRIX X370-I GAMING. And this is what I found after comparing this one to the ASUS ROG STRIX X470-I GAMING:

 

ASUS ROG STRIX X370-I GAMING

Windows 10 with Microsoft USB 3.1 drivers -> Issues.
Windows 10 with AMD USB 3.1 drivers -> There are no issues!
Fedora Linux 29 -> Issues.

ASUS ROG STRIX X470-I GAMING

Windows 10 with Microsoft USB 3.1 drivers -> Issues.
Windows 10 with AMD USB 3.1 drivers -> Issues.
Fedora Linux 29 -> Issues.

 

This leads me to conclude that there is no proper device driver support for the USB Redriver chip which is needed to transmit the signal to the more distanced port. Only the ROG STRIX X370-I GAMING works under Windows 10 with the AMD 3.1 device drivers designed for Windows 7. None of the two boards works properly under Linux. AMD did not update the USB drivers for over than a year now.

 

When is AMD going to provide proper device drivers for their products? I already RMAed the motherboard twice. I also tried another couple of ASUS ROG STRIX X470-I GAMING motherboards which I purchased from amazon. Only to return them afterwards because none of them worked properly. Finally I came to the conclusion that the problem is most likely related to device drivers. So there is no point in sending the motherboards back to the manufacturer for repair.

Outcomes