AnsweredAssumed Answered

AMDRewards Refusing to detect my RX Vega 64

Question asked by esos on Mar 15, 2019
Latest reply on Mar 16, 2019 by esos

I've gotten my GPU in December, and have been working on and off to solve this problem. Every time I enter in my correct coupon code from Newegg, the message: "A qualifying AMD product was not detected in your system. Please install the qualifying AMD product and try again."   

 

I already have my RX Vega 64 as my Discrete, primary GPU. I have proof attached to this post. I have troubleshooted many times. I already had hardware acceleration turned on in Chrome. I tried Firefox and Opera to no avail. I was really hoping to play The Division 2. I've contacted AMD Rewards support twice, first time I got a stupid automated response telling me to do the things that I've already done. I haven't gotten a response for my second one, it's already been a week. 

 

I've also tried the Product Verification Tool, but that program literally does not even launch. It shows up in task manager for like 2 seconds and crashes immediately. 

 

If anyone has a possible solution that I have not tried, I will try it with no hesitation. I've offered to give proof and everything they need to AMD Rewards, no answer. Please help me, I am desperate. 

Attachments

Outcomes