sherrera

RX 570 Failing Code 43

Discussion created by sherrera on Mar 11, 2019

Hi, ill try to make this as clear and short as possible. I bought a second hand reference Rx 570, and I tried installing it on my dads battlestation which has a pentium g4560 paired with a h110m-pro-vd-plus, a Rx 460 and a 400w psu. (Windows 10 x64)

So after plugging in the Rx 570 I started the system in safe mode, uninstalled all the previous drivers with DDU, and after that I installed the Rx 570 drivers from amd page.

Device manager recognized the card after that as a Rx 570, but it said that windows disabled it because it presented itself with an error code 43.

Also whenever I try to open amd settings it says that there is no graphic driver installed or it is not working properly.  

 

Things Ive tried so far: 

 

-Installing older drivers (always uninstalling previous with ddu first)

-Updating chipset drivers from motherboard

-Everything from here Troubleshooting Common AMD Graphics Driver Installation Problems 

-Secured the 6pin connector from the gpu (Just in case it was not getting enough power)

-Uninstalled device AND drivers from device manager 

-Hard restart / shutdown several times and pushed the power button for 1min+

 

Im running out of ideas and I dont want to think that the card is indeed broken, what else can I try to install the card?

Should I re-flash the bios? 

Thank you in advance.

 

PD: Tomorrow Im planning on building a brand new system with this card, so I will know if this is a gpu issue.

Outcomes