mechgineer

Trouble with Mobility GPU drivers

Discussion created by mechgineer on Mar 5, 2019
Latest reply on Mar 5, 2019 by pokester

System: Dell Inspiron 17R 5737

AMD Graphics Card: Radeon HD8870M
Desktop or Laptop System: Laptop
Operating System: Windows 10 64bit
Driver version installed: 18.1.1, attempted upgrade to 19.3.2
Display Devices: Laptop Monitor
Motherboard + Bios Revision: Latest BIOS from the manufacturer
CPU/APU: i7-4500U
RAM: 8 GB

 

The issue

----------------------------------

I stayed for a long time with my graphics card working perfectly with the 18.1.1 installed drivers. After trying to install the latest version (19.2.3), my computer froze while installing the AMD driver; the percentage of the installation when it hanged was not visible. A few seconds before freezing, I got a short notification from Windows saying that it was trying to set up a PCI bus—whatever that meant. Afterwards, Windows would freeze when loading, after the loading logo had disappeared, and I could not get it working at all; I didn't get any BSOD.

 

After browsing some forums, I used the DDU to clean my drivers and tried to install the 18.1.1 drivers again; this resulted in a failure, since the same message about the PCI bus would show up at one point, and it froze my computer again, without being able to start windows afterwards.

 

After some more reading, I updated Windows to the latest build, installed the latest Intel Graphics Driver, deleted everything from the C:/AMD folder and disabled my internet connection. All the while, the System ► Advanced system settings ► Hardware ► Device Installation Settings was turned off, to prevent Windows from messing with its own crappy and useless driver; the Event Viewer didn't show anything strange about crashes or anything. I attempted to try another installation of 18.1.1, but it froze again, and Windows could not start again.

 

I also tried installing an earlier version of the AMD Crimson 17.1.1 driver, but the respective driver was shown in Device Manager to be causing problems with the system, and the GPU was turned off.

 

 

How the hell could AMD screw up so badly? It ran perfectly since the last time I updated the drivers a while ago, and now, with this update, I can't run any sort of driver on it at all, my card currently has the useless 15.200.1045.0 driver, and I can't access my card to use it at all. I don't have the slightest suspicion that my graphics card broke down, since it would too big of a coincidence to be all happening when trying to install the 19.2.3 driver. But how the hell could it break down every other driver installation for this card? I haven't tried any other version of Adrenalin of Crimson, but two previously working versions have stopped being valid for my card for some stupid unknown reason.

 

I would very much like some feedback as to why AMD would break their own lineage of drivers, not just one particular version of it. Are they trying to make people buy new systems by hampering people's perfectly-running PCs?

 

Do you have any info/support about the issue?

 

Thanks!

Outcomes