nicocat

FreeSync stuck at 60-65Hz in Windows

Discussion created by nicocat on Feb 25, 2019

I have an R9 290 and just recently got a 144Hz monitor for the first time. It supports FreeSync, which I of course turned on. But I noticed some odd behavior:

 

1) After coming out of a game or even a benchmark (like, say, Furmark) which was running well above 60 fps, the monitor reverts to a 60-65Hz refresh rate. Windows (Win7 64 bit) still says it's at 144Hz but it's definitely at 60ish (confirmed with the OSD on the monitor).
2) Changing refresh rates in the Monitor settings in Windows is usually ok, but sometimes it decides to hang at a black screen and force a restart.

3) Toggling Freesync off and back on in the Radeon settings restores it to 144Hz, so far without issue.

4) Sometimes the screen won't wake from being asleep (the monitor went to sleep, the whole computer didn't).  Usually hitting ctrl-alt-delete will trick it and bring things back, but not always.

 

I tried disabling everything that could be considered an "overlay" (Steam, F.Lux, etc.) but it doesn't seem to help. Also tried with a couple of different drivers (from 18.9.3 to 19.2.3).  Has anyone run into this before?

 

Couple extra points:

 

1) Using the DisplayPort output on the 290
2) No other monitors attached (there's a DVI cable attached to the card but it's not hooked to anything, other monitor died on me)
3) Monitor is a Viotek GN27DB

Outcomes