mekanic1

Blender ProRender 2.0.1 "No Compatible GPUs"?

Discussion created by mekanic1 on Feb 24, 2019

This site was suggested by devtalk.blender.org.

1) MacOS 10.14.3 (Mojave)

2) MacBook Pro 2017 (Radeon Pro 560)

Have tried to install Recent release of Blender ProRender 2.0.1 on both standard Blender distribution and compiled versions. 

The Addon installs successfully in all cases, However, Blender User Preferences => System reports "No compatible GPUs" under OPENGL.

Any Suggestions on how to proceed/troubleshoot?

Blender "addons" are unfamiliar territory.....

 

FollowUp:

CPU device capabilities: SSE2 SSE3 SSE41 AVX AVX2

OpenCL device capabilities:
Number of platforms: 1
Platform #0
Platform Name: Apple
Platform Vendor: Apple
Platform Version: OpenCL 1.2 (Oct 31 2018 21:59:22)
Platform Profile: FULL_PROFILE
Platform Extensions: cl_APPLE_SetMemObjectDestructor cl_APPLE_ContextLoggingFunctions cl_APPLE_clut cl_APPLE_query_kernel_names cl_APPLE_gl_sharing cl_khr_gl_event

 

I believe I have my answer!....

FollowUp.(2) rprblender.log

2019-02-24 07:24:32,825 rpr.core [4764206528]: INFO RPR Core version 0x10032500
2019-02-24 07:24:32,852 rpr.core [4764206528]: INFO RPRX Support version 0x2
2019-02-24 07:24:32,854 rpr.core [4764206528]: INFO Image Filters version 0x1
2019-02-24 07:24:32,859 rpr.default [4764206528]: INFO rprsdk_bin_path: /Users/mikekuhnkey/Library/Application Support/Blender/2.80/scripts/addons/rprblender
2019-02-24 07:24:32,860 rpr.default [4764206528]: INFO Registering plugin with: tahoe_path=/Users/mikekuhnkey/Library/Application Support/Blender/2.80/scripts/addons/rprblender/libTahoe64.dylib, cache_path=/Users/mikekuhnkey/Library/Application Support/Blender/2.80/scripts/addons/rprblender/.core_cache/0x10032500
2019-02-24 07:24:32,871 rpr.default [4764206528]: INFO Plugin is registered: plugins=[0], cpu_device={'flag': 1040, 'name': 'matchingDevices(0) != 1'}, gpu_devices=[{'flag': 1025, 'name': 'AMD Radeon Pro 560 (Metal)'}]
 
To me this looks OK?  Is Blender perhaps confused about "Metal"?
I'm grasping for straws here.....
1) Blender "initialization" performs device search based on Cycles render engine?
"No Compatible GPU found"
2) Addons occur after initialization phase?
Radeon ProRender is identified

Outcomes