AnsweredAssumed Answered

Radeon Settings Won't Open

Question asked by wddplayer on Feb 20, 2019
Latest reply on Feb 22, 2019 by goodplay

Relevant system specs:

Windows 10 64 bit

i7-8700k

Radeon VII (Problem occurred with my Vega64 as well)

 

For some reason, no matter what I try, I can not get the radeon settings application to open on my PC. This problem has persisted for me some time now but it didn't bother me much because I use OBS for recording and MSI Afterburner handled the overclocking and undervolting of my Vega64 just fine. However, I am unable to tweak any settings for the VII using afterburner leaving me to rely on the Wattman software I can't access.

 

I have been scouring the internet looking for solutions since I got my Radeon VII two days ago and have tried every single one I could find. I have ran DDU, made sure to do clean installations, got windows completely up to date. I have done this with versions 19.2.2  , 19.2.1 and 19.1.1 and I am fairly certain I had the same problem when I was using my V64 with 18.11.2. I did the clean installs of each version after running DDU each time and with both my VII and V64 but nothing has worked so far. When I check the Reliability History it shows "Radeon Settings: Host Application Stopped Working.

 

At this point the only thing I haven't tried is doing a fresh install of Windows 10, which isn't exactly an easy task in my current setup that lacks a dvd drive and I don't own windows on a USB. And I have seen other people attempt that with no success anyway. Any suggestions at all? I would really love to be able to get into the settings and play around with the Radeon VII. It's a real bummer only being able to plug it in and leave everything stock. (Especially that fan curve while I wait on an EK waterblock)

Attachments

Outcomes