AnsweredAssumed Answered

NUC 8i7HVK atikmdag.sys BSOD, system rollbacks/file losses

Question asked by faded_memories on Feb 20, 2019
Latest reply on Feb 20, 2019 by kingfish

I have had a new Hades Canyon NUC for a couple weeks now and have been having multiple issues.  

 

It was purchased to use with a HTV Vive setup. Within a couple days I started having all sorts of trouble getting the machine to boot up and I sometimes saw BSOD pop up as well as losing files.

 

It took a while to track down the pattern, but initially I was seeing problems that seemed to be related to which displays were plugged into the machine, in which order/timing, and to some extent affected by use of a HDMI to DVI adapter.

 

I narrowed it down to the PC not booting properly if the Vive was connected to the front HDMI port.

 

Sometimes as I swapped cables around I would catch an error message, or some evidence of another boot cycle etc and even find files missing once I got logged in to the desktop.  (For example, with Vive in front HDMI port my TV screen would stay dark, but if I unplugged both HDMI cables and moved the TVs cable to the front I would eventually get a picture again.  Sometimes it would be at the login screen already, but sometimes it would be starting over, on the NUC splash screen, etc.)

 

Intel eventually got back to me with an explanation, at least regarding why the machine wouldn't boot properly with the Vive in the front HDMI port:

 

The boot order of the video ports is Thunderbolt ports first, then the Display Ports, then front HDMI and finally rear HDMI.  Stopped hanging on boot and worked reliably once I left the TV (main screen) plugged into the front port and Vive on the rear.  All was good (enough), or so I thought...

 

After not using the machine for a couple days I fired it up last night and immediately noticed I was missing files....it had obviously rolled back to a restore point, again.  I didn't see a Blue Screen but I think its still doing the same thing as before.

 

 

Earlier, I had thought that the wiring configuration of my display devices and the DVI adapter had been causing the BSOD error somehow. (Like a communication from the PC not getting an answer back from the device or something?)  Maybe the issues with it not liking the Vive in front etc were a concurrent coincidence and not a cause-effect situation?

 

 

Error in question, at least all the times I was able to catch the Blue Screen, was as follows:

 

Stop Code: System_Service_Exception

What failed: atikmdag.sys

 

 

 

What is making me crazy is that this error, or some variation of it seems to be all over if you do a web search and often unsolved.  Additionally it is said to possibly be caused by hardware OR driver problems and no easy way to narrow down which.

 

I have the latest recommend Radeon driver for this machine installed, but I have found others.  It looks like maybe there are newer revisions available, even from the Intel download site.  These newer ones are referencing the GPU family but not specific machines, while the one I am currently using is the newest one listed SPECIFICALLY for my machine.  Sounds like other users are running with the newer version.

 

I have run memtest86 a couple of times now with no errors noted.

 

 

Relevant numbers:

 

NUC8i7HVK

Windows 10 Home

 

Samsung 970 Pro  512GB NVMe M.2

2 x 8 GB Corsair Vengeance DDR4 2400MHz RAM

 

Currently installed Radeon driver package is 24.20.11026.2001   (18.9.1)

 

I see 18.12.2 available here (Download Radeon™ RX Vega M Graphics )

Mine is from (Download Radeon™ RX Vega M Graphics Driver for Windows® 10 64-bit for Intel® NUC Kit NUC8i7HNK, NUC8i7HVK )

Could there be as issue with the driver I have? And if so, should I try on older recommended one or maybe try the newer one as above?

 

Thanks!

Outcomes