technomancer87

RX580 8GB causing PC to restart!

Discussion created by technomancer87 on Feb 20, 2019
Latest reply on Feb 20, 2019 by technomancer87

First, the PC specs: 

 

MOBO: Gigabyte Z68ap-d3

Core i5 2500K (currently not overclocked)

16GB RAM

XFX RX580 8GB GPU

Corsair X600 600W 80plus gold Power supply

 

Last night I upgraded my GPU from a Radeon R700 series 2GB to the new one specified above. All seemingly went well installing the new drives, and swapping cards out. Booted up and everything seemed to be going smooth... Until I went into games. started off with some of my older or less graphically intensive games like Diablo 3 and MTG Arena. Played those fine, GPU would top out at around 55-60 Celcius....

 

The very next game was Apex Legends. My old card ran it (barely), so this card should no problem right? Well, I  booted it up to start changing the settings, and after roughly 2 mins, the screen goes blank and my PC restarts. No BSOD or any other warning. The PC boots and I go into the AMD settings and looked at some things, but didn't change anything. I tried an older game (but still pretty recent) Dark Souls 3. was able to go into settings and change to high or max, and ran for roughly 5 mins before doing the same thing. This time I was monitoring the Temperature. It never rose about 75 Celsius and the card was not physically hot, and the fans kicked in just fine. 

 

Apparently, this is a common issue with based on research, but the solutions didn't yield any different results. Tried changing the WattMan setting to allow higher PSU load (went up to +50% and even down to -20% and still the issue persists. Any help with his is greatly appreciated! Thanks in Advance!

Outcomes