AnsweredAssumed Answered

Radeon rx560 and black screen when playing

Question asked by purpur on Feb 9, 2019
Latest reply on Mar 17, 2019 by purpur
  • AMD Graphics Card: AMD RX 560
  • Desktop 
  • Windows 10 Pro 64bit
  • Driver version installed: Adrenalin 2019; 19.1.1
  • Display Devices: ASUS XG32V; 2560x1440; 144 Hz; DP to DP
  • Motherboard + Bios Revision: ASUSTek P7H55-M PRO, SMBIOS version 2.6
  • CPU/APU: Intel i5 750 (2.67 GHz)
  • Power Supply Unit  Make, Model & Wattage: Corsair VX 550
  • RAM: 8 GB

 

I have experienced problems with my pc for around a month. When opening any game after the game has fully loaded the menu screen (or whatnot) is visible for few seconds after which the screen turns blank and monitor shows message "DisplayPort has no signal" (or quite similar to that, don't remember exact phrase). The monitor / game / pc does not recover. Alt tabbing back to windows returns the image. Alt tabbing back to game returns the black screen. When restarting the pc there is an announcement from graphics drivers about "Default Wattman settings have been restored due to unexpected system failure".

 

I have tried googling and fiddling with wattman settings but I am no pro with those. I tried changing several settings (but I have no idea if I did changes correctly - voltage for gpu and frequence for gpu) but no help.

 

Yesterday my pc started shutting down few minutes after being started even without running any games. More googling followed, and I disabled overlay from drivers. Seems to have fixed this immediate issue. 

 

Still, can not run games. I tried removing drivers  with AMD's cleaning tool, and reinstalled newest drivers. Same problems. Clean -> version 18.x.x. No help. Clean -> 19.1.1. No help.

 

Odd thing is that initially I assumed the problem being related to a single game and while looking for support for that game I run into advice of removing media player from windows features, restarting, re-enabling it. This allowed me to play the game for an hour or few, after which I turned pc down. After next start up the problem was there again.

 

Any ideas? Help would be much appreciated.

Outcomes