AnsweredAssumed Answered

Performed a fresh install of the 19.2.1 everything is good, Till Restart - No Sound & USB Ports Stop Working after Windows loads.

Question asked by theanticuck on Feb 7, 2019
Latest reply on Mar 17, 2019 by artisresistance8

I was installing an AMD RX 480 on my Windows 10 64bit Desktop, the Mb is an EVGA P55 FTW 200 Bios AMIBIOS 08.00.16 with an i5-750 and 16gb of ddr3, the Driver was Radeon Software Adrenalin 19.2.1, I tried the couple of versions before with no luck. After using UDD to remove old driver, performing a fresh install of the New Driver everything is good. In-fact I can perform these procedures up to this point and everything will run Quite Nice! It's just the Fact that the Computer needs to be restarted. When I restart the computer nothing abnormal happens, the bios loads, my keboard and mouse light up, Windows begins to boot, the loading screen comes on for 5 or 10 seconds then my Keyboard goes dark as well as my mouse. I had a small duel usb single port pci card in my desk, I installed it so I could try to fix the problem. I noticed I had no sound, the AMD HD Sound Device was missing. I run an HDMI out to my tv and optical audio to my receiver. I make my way to the Device Manager and the Universal Serial Bus controllers header is open with 2 Identical lines Unknown USB Device Invalid device descriptor with the Yellow Reclamation sign, if you open properties of either of these you get : Code 43 - USB device returned an invalid USB device descriptor. I have reinstalled the drivers 3 or 4 times with the same result at restart. I stopped the automatic update of Hardware drivers by windows but this did not help either. The Card runs great, just the small detail of no sound and the USB ports. Thank for taking a look at this. Just to see if the problem was related to the Video Card Change, I did reinstall my MSI R9 290x Lighting, erased all drivers, installed new drivers and no issues. Sound works, USB works as designed. Multiple restarts, loading and running games. 

Outcomes