AnsweredAssumed Answered

Ok, another question about activation addon in Blender...

Question asked by ao.alyaev on Jan 11, 2019

I'm using 64-bit Blender 2.79b, 'standart', official release, no 'nightly', 'daily', 'after-lunch' builds or something like that. Hardware configuration seems to be ok, 'cause I'm working on notebook, Lenovo ideapad 110. After few attempts to activate addon that fails, I've tried install Python separatly, just for testing - nothing. As I've noticed, at first failed activation addon return this message to log:

Traceback (most recent call last):

  File "C:\Program Files\Blender Foundation\Blender\2.79\scripts\modules\addon_utils.py", line 350, in enable

    mod.register()

  File "C:\Users\Анатолий\AppData\Roaming\Blender Foundation\Blender\2.79\scripts\addons\rprblender\__init__.py", line 177, in register

    from . import render  # import render first to initialize pyrpr(can be used in other modules)

  File "C:\Users\Анатолий\AppData\Roaming\Blender Foundation\Blender\2.79\scripts\addons\rprblender\render\__init__.py", line 118, in <module>

    assert pyrpr_init(bindings_import_path, rprsdk_bin_path)

AssertionError

 

At second try it return this:

Traceback (most recent call last):

  File "C:\Program Files\Blender Foundation\Blender\2.79\scripts\modules\addon_utils.py", line 350, in enable

    mod.register()

  File "C:\Users\Анатолий\AppData\Roaming\Blender Foundation\Blender\2.79\scripts\addons\rprblender\__init__.py", line 178, in register

    from rprblender.render import engine

  File "C:\Users\Анатолий\AppData\Roaming\Blender Foundation\Blender\2.79\scripts\addons\rprblender\render\engine.py", line 14, in <module>

    import rprblender.core.image

  File "C:\Users\Анатолий\AppData\Roaming\Blender Foundation\Blender\2.79\scripts\addons\rprblender\core\image.py", line 10, in <module>

    from . import nodes

  File "C:\Users\Анатолий\AppData\Roaming\Blender Foundation\Blender\2.79\scripts\addons\rprblender\core\nodes.py", line 14, in <module>

    import rprblender.node_editor

  File "C:\Users\Анатолий\AppData\Roaming\Blender Foundation\Blender\2.79\scripts\addons\rprblender\node_editor.py", line 3, in <module>

    from rprblender.nodes import get_node_groups_by_id

  File "C:\Users\Анатолий\AppData\Roaming\Blender Foundation\Blender\2.79\scripts\addons\rprblender\nodes.py", line 883, in <module>

    from .node_thumbnail import get_node_thumbnail

  File "C:\Users\Анатолий\AppData\Roaming\Blender Foundation\Blender\2.79\scripts\addons\rprblender\node_thumbnail.py", line 8, in <module>

    import rprblender.render.scene

  File "C:\Users\Анатолий\AppData\Roaming\Blender Foundation\Blender\2.79\scripts\addons\rprblender\render\scene.py", line 11, in <module>

    import rprblender.render.render_layers

  File "C:\Users\Анатолий\AppData\Roaming\Blender Foundation\Blender\2.79\scripts\addons\rprblender\render\render_layers.py", line 9, in <module>

    import rprblender.render.device

  File "C:\Users\Анатолий\AppData\Roaming\Blender Foundation\Blender\2.79\scripts\addons\rprblender\render\device.py", line 7, in <module>

    import pyrprx

ImportError: No module named 'pyrprx'

 

 

And both of this messages appear in that order each time I try to activate addon in just opened Blender.

Outcomes