8 Replies Latest reply on Jan 18, 2019 1:08 PM by colesdav

    Some strange program & monitoring behavior after replacing a faulty GPU in a CrossFire setup. Any advice how to fix it?

    onewithwaves

      Hello and thanks for taking a look at my question! I've been building PCs for over 10 years and this issue has me totally perplexed; any and all advice is very appreciated! Sorry for following AMD's template but I'm a new user and don't want to anger the community on day one.

       

      Describe your system:

      • Custom ATX desktop
      • AMD Graphics Cards:
        • Sapphire NITRO+ RX 480 8GB x2 (Crossfire setup)
      • Operating System:
        • Windows 10 Pro 64-bit (most likely ver. 1803)
      • Driver version installed
        • Adrenalin 2019 Edition 18.12.3 (Optional)
      • Display Device
        • Acer XG270HU, DisplayPort connection (fully DP compliant cable)
      • Motherboard + Bios Revision
        • ASRock Z87 Extreme4, latest beta BIOS (it's far newer than the latest stable and both are several years old)
      • CPU
        • Intel i5-4670K (OC to 4.2GHz)
      • Power Supply Unit Model & Wattage
        • EVGA Supernova G2 750W
      • RAM
        • 16GB

      Describe your issue:

      I've been running an RX 480 since they came out and I love my Nitro+ so much, I wanted to get it a friend on eBay. The first card I got had clearly been used for mining and had lots of problems; it didn't always power on with my system, sometimes my MOBO reported it didn't support UEFI when powering on, etc., and I returned it as not working. I got another card which is in much better shape and doesn't throw any errors on me but I have lingering issues I expect are from the old shoddy card (not sure how that would be possible but it's the only thing that's changed). When I first set up CF I was getting ~%150 scaling in Overwatch and all my monitoring programs worked perfectly (I use Afterburner to display hardware stuff on my G13's LCD). After the (old, bad) card threw a few fits, Afterburner stopped reporting GPU load correctly and OW and other CF capable titles stopped scaling at all; even with CF turned off, they ran far worse than they did before I set up CF. After getting the second (good, working) card, most games scale properly again but Afterburner and HWinfo64 are still not reporting GPU load at all; both cards constantly read 0%. I also have some issues with microstutter and CF scaling that weren't there before. For example, Overwatch runs in CF when connecting to the server and entering the game, but CF suddenly turns off once the menu loads (I have the CF logo turned on for troubleshooting purposes). I've even specified the AMD profile for Overwatch with no improvement. I'm it my wit's end trying to figure out what went wrong and what sort of gremlin that dead card left in my system - what do you think could get me up and running at 100% again?

       

      So far, I've attempted totally uninstalling AMD's driver using DDU in Safe Mode and performing a clean reinstall of the latest Adrenalin driver. I've also totally uninstalled and reinstalled Afterburner, both the latest and Beta versions. I've tried enabling Unified Monitoring in Afterburner, disabling ULPS, disabling Power Efficiency in Radeon Settings, toggling global CF on and off and disabling my CPU's iGPU in my BIOS but haven't been able to resolve this issue. As I said before, any and all help is greatly appreciated as I've run out of ideas at this point.