leecope3

RX580 keeps crashing my pc.

Discussion created by leecope3 on Jan 7, 2019

AMD ryzen 5 1600x
Asus Prime X370 pro

16 gig Corsair Vengence DDR 4

MSI RX580 8 Gig Armor
Corsair TX 750w 80+ gold psu

So, recently my pc started crashing while gaming, firstly i decided to go with a full windows reinstall to rule that out. that did not solve the problem,

as the card is 18 months old i RMA'ed it top scan. they tested the crap out of it and decided it was fine, no fault found. scan recomended i got the PSU replaced by corsair.

i was running a CS750 80+ gold, corsair didnt even test it they just sent me the new TX750. put pc back together and everything seemed fine for a couple of weeks or so.

now its crashing whenever i try and play a game. loading up destiny 2 as the game loads in my fps counter is up and down, game is "laggy" and before i can load in to a map its crashed, picture goes off the screen, PC case stays lit up as does my mouse and keyboard, machine will not post or restart unless i use the reset button or power button.

 

tried the DDU program, removed all trace of the AMD drivers in safe mode. rebooted and reinstalled freshly downloaded drivers from amd site (most recent). windows is up to date, have made sure bios is also on most recent and checked all my drivers on the machien are updated, but this has not sorted anything out.

i am going to post some info from win DBG as i think it is relevent and might help someone identify my issue,

 

VIDEO_TDR_FAILURE (116)
Attempt to reset the display driver and recover from timeout failed.
Arguments:
Arg1: ffff8d0d2ea76010, Optional pointer to internal TDR recovery context (TDR_RECOVERY_CONTEXT).
Arg2: fffff803a29404d0, The pointer into responsible device driver module (e.g. owner tag).
Arg3: ffffffffc0000001, Optional error code (NTSTATUS) of the last failed operation.
Arg4: 0000000000000003, Optional internal context dependent data.

FOLLOWUP_IP:
atikmpag+104d0
fffff803`a29404d0 48895c2408 mov qword ptr [rsp+8],rbx

FAULT_INSTR_CODE: 245c8948

SYMBOL_NAME: atikmpag+104d0

FOLLOWUP_NAME: MachineOwner

MODULE_NAME:
atikmpag

IMAGE_NAME: atikmpag.sys

DEBUG_FLR_IMAGE_TIMESTAMP: 5c09c07a

STACK_COMMAND: .thread ; .cxr ; kb

FAILURE_BUCKET_ID: 0x116_IMAGE_atikmpag.sys

BUCKET_ID: 0x116_IMAGE_atikmpag.sys

PRIMARY_PROBLEM_CLASS: 0x116_IMAGE_atikmpag.sys

TARGET_TIME: 2019-01-07T19:34:47.000Z

OSBUILD: 17134

OSSERVICEPACK: 472

SERVICEPACK_NUMBER: 0

OS_REVISION: 0

SUITE_MASK: 784

PRODUCT_TYPE: 1

OSPLATFORM_TYPE: x64

OSNAME: Windows 10

OSEDITION: Windows 10 WinNt TerminalServer SingleUserTS Personal

OS_LOCALE: 

USER_LCID: 0

OSBUILD_TIMESTAMP: 2018-12-14 06:53:05

BUILDDATESTAMP_STR: 180410-1804

BUILDLAB_STR: rs4_release

BUILDOSVER_STR: 10.0.17134.1.amd64fre.rs4_release.180410-1804

ANALYSIS_SESSION_ELAPSED_TIME: 1846

ANALYSIS_SOURCE: KM

FAILURE_ID_HASH_STRING: km:0x116_image_atikmpag.sys

FAILURE_ID_HASH: {e300aa8c-6915-3f37-7957-d2e4fc30a6fd}

Followup: MachineOwner
---------
i am honestly at my wits end with this machine as usually driver issues are easy enough to resolve, any help from any of you guys would be mostly appreciated,

note: i had a win update to do but no effect on crashing

Outcomes