AnsweredAssumed Answered

RX 580 Displayports not working

Question asked by vangeroth on Jan 6, 2019
Latest reply on Jan 8, 2019 by vangeroth

So I've had my Rx580 for over 6 months now so I have no way to send it back, but it seems that both of the Display Ports on my MSI RX580 do not work. I got a new/used monitor from my fathers office who were getting rid of them and I did confirm the monitor works. It only has VGA and DVI but I have it hooked up to a DVI to HDMI adapter and then from there to a HDMI to Displayport adapter. The DVI-HDMI adapter does work and I confirmed it does by plugging it into the port that my existing HDMI monitor is plugged into. Also for the record both HDMI and the one DVI port on the card do work.

 

I have never had a reason to use the Display Ports on my card until now. Both actually had the plastic insert covers in them until I got the hand-me down monitor. So if those are bad then I am boned out $300+ for a card that only half works. :/

 

Any sort of help would be greatly appreciated. The HDMI to Displayport adapter is brand new because I had to buy it just to get the new monitor to be usable. So while it's very unlikely that the adapter is bad (I just bought with within the last few hours), I can't really rule it out with how low quality things like it are made these days. The adapter is one I bought from Best Buy and is branded by Insignia. Thing costed $25 too.

 

I've done a GPU driver wip and reinstall but did not fix the issue. I've done the whole process I've seen around that says to unplug your monitor, turn of your PC, so on and so forth. Also did not work.

 

So either the brand new adapter I just bought it bad, or the card that's well past the return policy has half of the features completely busted and I am only now finding out. Suffice to say I am pretty frustrated.

 

Thanks for anyone who can lend a hand.

Outcomes