AnsweredAssumed Answered

The Witcher 3 & Arkham Knight locked at 30 fps on R9 390,what's an issue?

Question asked by frozen_sun on Jan 6, 2019
Latest reply on Jan 7, 2019 by frozen_sun

Well I own Asus Strix R9 390 graphics card and have this weird issue with locked fps in these 2 games at 30.I turned v-sync OFF.

I play on 2560x1080 (ultrawide LG monitor), and even if I switch to 1920x1080 I get only few fps more, 4-5 (Witcher 3)

In all settings at HIGH I get only 30 fps,if I switch to ULTRA I get around 25 fps only.

Now I searched on youtube the results other guys got with R9 390, and you can see I should get around 50 fps and even more in ultra settings.

The card doesn't overheat at all.My cpu is I7-6700k.

I had same problem with Far Cry 5 until I didn't install newest AMD drivers and problem was solved.But not in these 2 games which I really do wanna play.

So anyone knows what could be an issue?

I know I had more fps on my previous monitor which was full HD and was connected via DVI cable,and now is HDMI and I don't know if that is the problem for limited fps,but then again I would have same 30 fps in all other games I play,which is not the case and on like all other games (newer ones) I get above 50 fps in high/ultra settings.

I did manage to solve the problem in Witcher 3 by turning off nvidia hairworks off by help of some dude on one forum which was awkward,and in Far Cry 5 updating to latest drivers,which you can see on pics below that I installed latest drivers for this card from your website.

How the hell can nvidia hairworks lower fps if it's not supported by AMD?

I haven't touch any of the crimson driver settings as you can see on pics everythins is default.

Even changing the resolution in Arkham Knight to 1920x1080 doesn't do nothing,Screen Shot 01-05-19 at 04.12 PM.JPG fps is simply locked at 30.

I did performance test in Arkham Knight as you can see on picture and FPS is as expected and way above 30.

I youtubed about r9 390 and arkham knight and on this card i should have 80-90 fps even in ultra settings,and I'm on normal settings.

Turning v-sync OFF or ON doesn' make any difference.There is no nvidia hairworks option in game.

Monitor is 60 Hz.

So any of your help is appreciated what to do to get normal FPS is this game like all other guys?

Please don't tell me uninstall drivers because in previous drivers I installed last year don't know which exact version I think it was 18.12. I had same problem,even Far Cry 5 didn't work above 30 fps.

And I don't want to reinstall OS since that is not an issue probably.

I even didn't ran MSI Afterburner reading on your forum that it can make issue with crimson drivers but still no help.

Here are the pics so you can look at settings:

Screen Shot 01-06-19 at 10.38 AM 001.JPGScreen Shot 01-06-19 at 10.38 AM.JPGScreen Shot 01-06-19 at 10.36 AM.JPGScreen Shot 01-06-19 at 10.35 AM 002.JPGScreen Shot 01-06-19 at 10.35 AM.JPGScreen Shot 01-05-19 at 11.00 PM.JPGScreen Shot 12-11-18 at 11.01 AM.JPG

Outcomes