AnsweredAssumed Answered

VEGA 64 Displayport 1.2 Limited Monitor Output Issue

Question asked by bhuvsta85 on Jan 5, 2019
Latest reply on Apr 17, 2019 by matthewfarren@gmail.com

Hello all,

 

I'm having issues getting my Vega 64 to display my monitors native resolution - 2160p60. If I set my monitor to Displayport 1.1 there are no issues acheiving 2160p30. However when I set my monitor to Displayport 1.2 I get several issues depending on which driver I have installed (I've tried a selection from 17.12.1 to 18.11.12):

 

17.12.1 - Limited to 1080p60 at DP1.2 (but 2160p30 at DP1.1) with the "The System has detected a link failure....." message.

18.3.1, 18.3.4 and 18.6.1 - Limited to 1080p60 at DP1.2 (but 2160p30 at DP1.1) but NO 'link failure' message.

18.7.1 and 18.9.3 - Limited to 1080p60 at DP1.2 (but 2160p30 at DP1.1) but NO 'link failure' message. These drivers actually have 2160p60 (and many other resolutions above 1080p60) but they all result in a blank screen and the display reverts to 2160p60.

18.11.12 to latest - Get a blank screen during driver install, which I assume is the drivers defaulting to 2160p60 without falling back to 1080p60.

 

I've tried a fresh install of Windows 10 but the problem still persists. Without an AMD graphics driver installed Windows defaults to 3840 x 2160 @ 64fps which appears to work ok.

 

There were no issues when I connected my PC to a UHD TV via HDMI 2.0. The PC successfully played a few games so I can assume that it's not a power consumption/supply issue. Unfortunately my monitor is limited to HDMI 1.4.

 

I was previously using a Sapphire R9 290 Tri-X with the same hardware and that had no issues with attaining 2160p60 using DP1.2 so I don't think it is an issue with the Displayport cable I'm using. I have tried Displayport cables of different lengths and even a DP to mini-DP cable.

 

I'm assuming this points to a driver issue with DP1.2. Any suggestions?

 

Mobo: Asus B350-F Strix (Latest BIOS)

CPU: AMD Ryzen 1600 (Default Speed)

RAM: 16GB 3400 Mhz DDR4

Graphics: Sapphire Vega 64 Nitro+

Monitor: Phillips BDM4065

OS: Windows 10

PSU: EVGA G2 1kW

Outcomes