AnsweredAssumed Answered

libGL error: failed to load driver: radeonsi, swrast

Question asked by kaengo on Dec 29, 2018

Hello!

I have running CentOS Linux release 7.6.1810 (Core) with Linux 4.20.0-1.el7.elrepo.x86_64.

I installed amdgpu-pro-18.50-708488-rhel-7.6, the pro-driver without any options.

Many demanding applications are running fine on the machine: ansys, gmsh, varicad, vmware player with windows7 and ptc creo and salome.

But one application crashes my X: salome-meca.

Now I startet salome-meca from a shell and got following error messages:

 

kaengo@localhost ~]$ /opt/salome_meca/appli_V2017.0.2/salome

runSalome running on localhost.localdomain

Searching for a free port for naming service: 2816 - OK

Searching Naming Service + found in 0.1 seconds

Searching /Kernel/Session in Naming Service ++libGL error: No matching fbConfigs or visuals found

libGL error: failed to load driver: radeonsi

mesa: for the -simplifycfg-sink-common option: may only occur zero or one times!

mesa: for the -global-isel-abort option: may only occur zero or one times!

libGL error: No matching fbConfigs or visuals found

libGL error: failed to load driver: radeonsi

libGL error: No matching fbConfigs or visuals found

libGL error: failed to load driver: swrast

Warning: this type (Study,objref) already exists, it will be ignored.

+****************************************************************

*    Warning: HYBRIDPLUGIN GUI resources are not found.

*    HYBRIDPLUGIN GUI will not be available.

****************************************************************

****************************************************************

*    Warning: BLSURFPLUGIN GUI resources are not found.

*    BLSURFPLUGIN GUI will not be available.

****************************************************************

****************************************************************

*    Warning: HexoticPLUGIN GUI resources are not found.

*    HexoticPLUGIN GUI will not be available.

****************************************************************

****************************************************************

*    Warning: NETGENPLUGIN GUI resources are not found.

*    NETGENPLUGIN GUI will not be available.

****************************************************************

****************************************************************

*    Warning: GHS3DPLUGIN GUI resources are not found.

*    GHS3DPLUGIN GUI will not be available.

****************************************************************

found in 1.5 seconds

Start SALOME, elapsed time :   1.7 seconds

 

Does anyone know, what I can do?

Of cause, I'm happy that most of the system is working and don't want to damage my system.

 

Greetings,

Holger

Outcomes