AnsweredAssumed Answered

Ryzen 7 1800X Missing CPU Pin

Question asked by trihard on Dec 29, 2018
Latest reply on Dec 29, 2018 by 7thsanctum

My Ryzen 7 1800X CPU arrived like two weeks ago and barely got around to putting it together now because I had to order a AM4 MB as well.
Today I began installing the parts and installed a AM4 MB and the Ryzen 7 CPU. I fit the CPU into the socket and it fit fine, no struggle or resistance at all with it. I put the heatsink on and connected everything and then tried to boot. Nothing. Not even to post. I checked the lights on my motherboard and it indicated an issue with the CPU. I took off the heatsink and CPU, looked at it, all the pins were there. I refitted everything and tried again, same issue. I took everything apart again, looked at the CPU and on the top left corner there was a missing CPU pin. I looked in on my motherboards socket and didn't see the pin. I'm assuming the reason why it's not working is because of this broken pin, and not because of a dead motherboard.
So, is there any way to fix a missing/broken pin? If so how?
Thanks in advance.

Attachments

Outcomes