AnsweredAssumed Answered

Gigabyte RX 580 Gaming Box performance issues and crashes in Doom

Question asked by merode on Dec 18, 2018

Hello everyone

 

I have performance issues and in some cases crashes running Doom. I have tried running two versions of it:

- full version (Steam, fully updated),

- demo (which I think was never updated since 2016).

In both cases I tried using both OpenGL and Vulkan. In case of OpenGL mode I get the same results in demo and full game: about 30 FPS whichever graphics preset I choose. I enabled statistics which show GPU timings are completly off: Doom thinks GPU times are astronomically high and I guess it assumes GPU utilization is at 100%, however it is not. Take a look at this screenshot which shows GPU timings in milliseconds (this very wide red row). I have reinstalled game, messed with config files - nothing helps.

 

In case of Vulkan, there are two outcomes. In case of demo I get instant game crash and callstack points to vkResetFences() in vulkan-1.dll. It might be due to the age of demo and dynamic development of Vulkan implementations. In case of full version, game starts and I get to initial loading screen. Even at this stage statistics are displayed and I notice that running Vulkan my GPU timings are correct and game would work flawlessly. However when it reaches 99% I get BSOD pointing to atikmdag.sys with error SYSTEM_THREAD_EXCEPTION_NOT_HANDLED.

 

My setup is:

- Intel Skull Canyon (NUC6I7KYK)

- Intel Core i7-6770HQ (4 cores, 8 threads)

- Gigabyte RX 580 Gaming Box (eGPU)

- 16GB DDR4 RAM

- Samsung Evo SSD

- fully updated Windows 10 (v. 1809)

 

Additional information:

- I'm connecting NUC to eGPU with 2m active TB3 cable rated for 40Gb/s (from Cable Matters),

- I have updated Gaming Box to newest, H2D firmware (v. F1.0_H2D),

- Gaming Box is running BIOS v. F1

- I have installed newest TB driver (v. 17.2.71.2),

- I have updated TB3 controller to newest firmware (v. 27),

- NUC is running almost the newest BIOS (v. 0058, there's already v. 0059 available which I will try today),

- I have reinstalled (unsintalled with DDU) newest AMD drivers (v. 18.12.2),

- This system has integrated Intel Iris Pro 580, which I have updated to newest driver (v. 25.20.100.6444) but it is not used. The display connected to it is disabled in screen settings of Windows.

- The only display that is enabled is connected directly to eGPU via DP cable.

- I have installed newest VulkanRT (v. 1.1.92.1) and all Vulkan demos (cube.exe) and my mini games work.

- To resolve issues I have tried disabling integrated graphics in device manager and even completly uninstalling it to no avail.

 

All other games and programs are working correctly. My benchmarks look fine and comparable to my friend's RX 580 running directly off PCI-E slot. I have reached out as well to Bethesda, Intel and Gigabyte.

Outcomes