AnsweredAssumed Answered

black screen when enabling A10 APU and RX 580 graphics at same time on Win 10

Question asked by easyrhino75 on Dec 16, 2018
Latest reply on Dec 22, 2018 by goodplay

hi!

I've had an AMD A10-7890k (with integrated R7 graphics).   Recently, I replaced my old Nvidia video card with a PowerColor Red Devil Rx 580.  I have only one monitor, and it's plugged into the RX 580 (into the DVI port).

 

Now, if I have the integrated GPU enabled (to use for secondary computing or whatever), then this process happens:

 

1) I see the motherboard BIOS screen displayed from the discrete card

2) I see the beginning of the Windows login (windows logo and basic spinny circle) displayed from the discrete card.

3) But by the time I get to the Windows 10 login screen, then my monitor is just "black".  It doesn't say there's no signal, but what I do have is just pure blackness.

4) If I unplug my monitor cable from the discrete 580 and plug it into the motherboard's, then my Windows display works!  (using the integrated GPU).

 

AMD Radeon Settings shows the integrated R7 as being the primary adaptor, and I don't see a way to change it so the RX 580 is primary.

 

Stats:

Graphics card:

* PowerColor Red Devil RX 580 w/ 8GB

* A10-7890k with integrated R7

Desktop system:

* homemade desktop

Operating system:

* Windows 10 Pro 64 bit  build 17134

Driver version:

* Radeon Adrenalin 18.12.2

* also used ver 18.9.3 extensively... same problem.

Motherboard:

* MSI A88XM-E45 V2 with bios 5.4

CPU:

* A10-7890k

Power Supply

* Antec High Current Gamer 520w HCG-520m

RAM

* 8GB

 

Debug stuff I tried:

 

1) So, if I disable the igpu in the motherboard BIOS, then then RX 580 works fine.  But I'd really like to leave it enabled, just not primary.  (the motherboard is configured to initialize the "PEG" first, which is why the beginning of the boot process is visible through the 580). It's just when the Windows driver is loaded that it switches over to the integrated GPU.

 

2) Tried complete driver uninstall (using safe mode DDU) and reinstall.  Didn't help.  Incidentally, the "Windows basic display drivers" didn't have this problem, I was able to use the Rx 580.

 

3) Tried disabling EnableULPS in regedit.  Didn't help.

 

Any ideas on how I can have both GPUs enabled but keep the RX 580 as the primary in Windows 10?

 

thanks!

Outcomes