AnsweredAssumed Answered

I can't update my graphics driver, please help me!

Question asked by sebastian502 on Dec 12, 2018
Latest reply on Dec 17, 2018 by sebastian502

Hi. I have a desktop PC with:

 

AMD A10 7700K APU (Integrated graphics is a Radeon R7, I don't use it)

Gigabyte GA-F2A68HM-DS2H MoBo

RX 460 2GB

8GB RAM DDR3

650W PS

Windows 10 Pro

 

I have it connected to a TV with HDMI

 

For some reason, everytime I reinstall Windows it always has an specific Radeon Settings version installed. I think it's 17.1.1 or something like that... It's like if Windows thought that's the right version and it ALWAYS installs it after a Windows reinstall.

 

Anyways, when I open Radeon Settings to update it to the latest version, I see no update button. There simply is no way inside Radeon Settings to update it. No update button at all.

 

So, I went to the official AMD site to get the latest drivers and install them manually (18.12.1.1 for me rn). I did NOT use the auto-detect tool. I also got DDU's latest version. I performed a clean install (also disabled Windows Update and Windows Defender, I don't have any other AV), rebooted into safe mode without internet, used DDU and then tried to install the new drivers... Installation goes fine BUT when it ends I don't get any "Restart Now" button, as how it's supposed to be. That's the sign something went wrong. I remember that a while ago I had this same issue and somehow resolved it, but I don't remember how. What I do remember is that I knew it had worked out if I saw the "Restart Now" button at the end of the new driver's installation.

 

(pd: sometimes the installation doesn't even end, it just goes into a black screen of death and I have to reboot 5 or 3 times to get back in safe mode, it sucks)

 

So, what's wrong if I don't get that button? I can just manually restart by myself and that's it, right? Well, once I do that and try to open Radeon Settings it tells me "Radeon Settings and driver version do not match". Radeon Settings won't open. Also, I see a weird "ID_STRING###" folder or something like that in my Windows Start menu. Also, when I go to the device manager, I see that in Display Adapters, the RX 460 looks just fine, but the R7 seems to have some kind of problem. AND, the most important thing: When I launch a game it runs super bad. I tried playing Fortnite, it ran at about 30fps. And it used to run at +80fps with 17.1.1, the version that Windows installs automatically! All this means there's something wrong. My system works just fine, it's the driver whats messing everything up. I need to update the drivers to run my other games better. Fortnite runs fine but many others don't, and that's why I need a newer driver.

 

I think this COULD be fixed with an update for people with systems like mine, you know, an old APU and an old graphics card in Windows 10... amdmatt pls

 

kingfish Please help me!

 

Thanks in advance for your attention and help.

Outcomes