AnsweredAssumed Answered

Ubuntu 18.10 RX 580 install error

Question asked by indiediva on Dec 12, 2018
Latest reply on Dec 13, 2018 by indiediva

I am having a recurring issue trying to install amdgpu-pro-18.40-697810-ubuntu-18.04 on my new system build. I run through the directions of extraction and [sudo ./amdgpu-install]. This tells me I have 124 files to install. During this process I get:

"Preparing to unpack .../023-amdgpu-core_18.40-697810_all.deb ...
ERROR: This package can only be installed on Ubuntu 18.04.
dpkg: error processing archive /tmp/apt-dpkg-install-OIjzah/023-amdgpu-core_18.40-697810_all.deb (--unpack):
new amdgpu-core package pre-installation script subprocess returned error exit status 1
"

 

At this point I can not update/upgrade any further software on my computer because I get errors like below where it forces me to install amdgpu-core.

sudo apt --fix-broken install
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Correcting dependencies... Done
The following additional packages will be installed:
  amdgpu-core
The following NEW packages will be installed:
  amdgpu-core
0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
123 not fully installed or removed.
Need to get 0 B/2,348 B of archives.
After this operation, 12.3 kB of additional disk space will be used.
Do you want to continue? [Y/n] y
Get:1 file:/var/opt/amdgpu-pro-local ./ amdgpu-core 18.40-697810 [2,348 B]
(Reading database ... 256255 files and directories currently installed.)
Preparing to unpack .../amdgpu-core_18.40-697810_all.deb ...
ERROR: This package can only be installed on Ubuntu 18.04.
dpkg: error processing archive /var/opt/amdgpu-pro-local/./amdgpu-core_18.40-697810_all.
deb (--unpack):
new amdgpu-core package pre-installation script subprocess returned error exit status 1
Errors were encountered while processing:
/var/opt/amdgpu-pro-local/./amdgpu-core_18.40-697810_all.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

 

This is a gaming build as I stream on Twitch, and I need the up-to-date drivers. I know there is the 18.04/18.10 issue, but it there a workaround, or do I have to downgrade to 18.04?

 

Thanks! (sorry about the ugly long post, I am new here)

Outcomes