AnsweredAssumed Answered

ryzen 2700x system performance problems.

Question asked by yoshirawr on Dec 9, 2018
Latest reply on Mar 15, 2019 by noodles59

New build

Cpu: Ryzen 2700x

Motherboard: Asrock x470 Master sli/ac bios 1.50 (came with 1.40 i believe)

Ram: T-Force Vulcan TLRED416G3000HC16CDC01 DDR4 3000 32GB

Video: GTX 970

SSD: WDS512G1X0C 512 GB NVMe

 

Alternate Parts tested

Motherboard: Asus Prime x470 Pro (bios 4024 now, came with 4016 i think?)

Ram: Crucial BLS4G4D240FSE.8FBD 16GB

Video: Different GTX 970

SSD: Intel 660p 2TB NVMe

SSD 3: Adata SX900 Sata 3

 

With fresh windows 10 installs the system either locks up or blue screens with a clock_watchdog_timeout error. Happens often enough to make installing windows updates and drivers a pain to do. If enough updates get installed the lockups and crashes stop and the system is usable. But if you update windows to feature update 1803 or 1809 a new set of problems occur. Once updated, the system will intermittently but frequently become very unresponsive. Can take anywhere from 10 seconds to a couple minutes to do something as simple as open the start menu or file explorer. Sometimes the system is effectively unusable right from boot. Other times its ok for a few min before the laggy responsiveness starts. I have installed all the latest drivers from the MB manufacturers websites for both boards. Newest Video drivers. I don't see any cpu spikes when this is happening in task manager. I have tried enabling and disabling HPET, tried the different power profiles (AMD balanced, balanced, high performance) without any noticeable change. Tried underclocking the CPU a bit, and over clocking a bit, no change. Heat is 35-50 idle, 50-60 in a game, eventually goes up to 85 with prime 95 running all cores at 100% but from what i can find online that seems normal with the stock cooler. Tried disabling the spectre mitigation with inspectre and no change either. DCP latency checker shows some dpc lag intermittantly, but doesnt always occur when the system is lagging so not sure how useful that was for this issue. Latency monitor says there are issues with kernel responsiveness while idle. I may have done other things that i cant remember at this point. I have reset the bios a few times and i dont have access to the asus motherboard anymore (returned it since the problem stayed with the processor instead of the MB) I dont have another processor to test here, everything else i have is intel. Im out of ideas at this point and I really dont like having to use an old version of windows 10 just to make it useable. If anyone knows anything i can try please let me know

 

Oh i forgot. Ive tried 3 power supplies, a 850W, 700W and a 550W. No change to the problem

 

Message was edited by: Yoshi Yoshi

Outcomes