0 Replies Latest reply on Nov 30, 2018 10:18 AM by thechickenadobo

    RX 570: AMD Error 173 Not Recognizing

    thechickenadobo

       

      Hi,

       

      I've replaced my old 560TI with an RX 570 but Windows 10 is not recognizing the GPU is plugged in.

       

      I removed my 560TI weeks before getting the RX 570 since it was breaking, so for a few weeks I've been running on the internal graphics card (Intel).

       

      I shut everything off and proceeded to install the RX 570. On first boot after attempting to install drivers, I was getting the Error 173 of "Not recognizing any AMD hardware".

       

      Here's what I've tried:

       

      Reseating the GPU (tried on both PCI Express slots)
      Changing the bios to force to use PCI
      Plugged in my old breaking GPU (This actually works)
      I've resetted my BIOS (Although I think I have, 90% sure, I had to unplug my CMOS Battery since I couldn't find the jumper pins)

       


      One thing I did do by accident, is boot the pc without realising I hadn't plugged the RX 570 to the PSU(600w).. I'm hoping this hasn't effected it, since the RX 570 looks to be running normally and lights up.

       

      After my attempts above, I get a blackscreen and no display input being detected whenever I have the RX 570 plugged in, even with setting the BIOS to run on Internal Graphics... (Changing the display outputs used, even with just a VGA cable plugged into the MOBO, I get no display)

       

      But with my 560Ti, the PC boots up normally with a display output

       

      My last try before giving up is plugging the RX 570 into my other PC and seeing if it works. (Will try this afterwork)

       

      Any Ideas? Have I got a faulty GPU?

       

      I've got a pretty old rig:
      i5-3570k
      600W PSU
      16GB Ram
      Old GPU was 560 ti

       

      It isn't a compatibility issue isit?

       

      Thanks