AnsweredAssumed Answered

AMD PSP 3.0 Device - Windows cannot initialize the device driver for this hardware.

Question asked by howdoicomputer on Nov 18, 2018
Latest reply on Feb 10, 2019 by shmakky

Hi guys,

 

I'm in enough of a bind right now to sign up for a forum! That, like, never happens!

 

At any rate, here's my issue: the AMD PSP 3.0 Device driver (which I admit I have a very very very very very limited understanding of through my Google-fu) is not being picked up by Windows, making me unable to boot into Windows using normal means (I'm typing this in safe mode). My attempt to uninstall it merely turned it into some vaguely-named driver, and disabling it does nothing helpful as well. I tried updating and manually installing the driver but Windows reports back that it's the most recent version.

This issue initially started after I downloaded and installed my mobo's chipset: Support For B350 PC MATE | Motherboard - The world leader in motherboard design | MSI Global . After trying to uninstall the PSP 3.0 driver, I tried to reinstall the chipset, but it gave me an error about not having the drivers signed. I looked all over the web - I can't be the only one having this issue, right?

 

Specs:

Mobo: MSI B350 PC MATE

CPU: AMD Ryzen 2600X

RAM: Corsair Vengance 16 GB DDR4 3000Mhz

PSU: EVGA 850 BQ

 

Software:

OS: Windows 7 SP1 64-bit

Driver: AMD PSP 3.0 Device

Outcomes