6 Replies Latest reply on Nov 6, 2018 5:15 PM by cimerea

    RX 480 fan going crazy

    cimerea

      Hello.

       

      I got me a MSI RX 480 GAMING X 8G about two years ago. I'm generally happy with the choice, but lately I've been having this wierd fan issue.

      While playing certain games the fan will go to 2400 rpm no matter the temp of the card. After closing said game, fan will not turn off but reduce spinning speed very very slowly, and after 5-10 mins it will finally turn off but the temp reported by WattMan will be in the 20-ies by then. It was bugging me, cause it's pretty loud when you're not playing anything, but it turned out that if I reset the WattMan profile to it's defaults, the fans will stop.

       

      From a few tests I ran I noticed fans start to go crazy when temp reaches 68*C, while games that don't experience this issue never go over 65*C. Which in itself is a little odd, since I run the card on default settings (auto puts temp curve at 73/90*C (target/max), rpm 522/2400 (min/target)). What's also strange about it is that the temp, while fans run at 2400, goes down to 56-57*C but the card doesn't mind and still runs them as fast as it can (peak fan speed up till now - 2438), like it's trying to disregard the limit.

       

      The issue became noticable a few driver versions ago. Maybe cause before that I played games that would make high GPU usage and fast fans reasonable (Witcher 3 to be exact). I was at Adrenaline 18.9.3 when I decided to do something about it, but the issue was there even before I updated the drives to that ver. I always installed my drives using "clean" option in the AMD Settings app. Earlier today I used DDU to remove the driver entirely and installed the last recommended ver.: 18.5.1 but it did nothing.

      Also before I decided to fight this thing, I was running the card on the factory bios. Thinking some settings there got outdated in the last 2 years I visited MSI forum and asked for the newest version, which I flashed later, Still nothing.

       

      I use no card management apps other than WattMan, cause 2 years ago, when the drivers were still messy (like they aren't right now ;p) the conflicts two apps generated were rather major.

      I also use default WattMan settings cause the ... thing resets them on a whim or if someone breathes too loudly, so why bother. In short - no OC, no UV, no manual temp curve or fan control.

      The games that generate the issue are pretty random. Witcher 3 on 2K and high settings didn't raise my suspicion, but 7 Days to Die, Thea: the Awakening or Eador: Masters of the Broken World are strange, especially the last two. The games that don't spawn the issue are among others: League of Legends, Civilization V.

      I run all my games in 2k, 144Hz and highest settings suggested by the game, both those with the issue and those without.

      I'd love to do something about it cause I'm afraid I'll tire my fans to death and/or my hearing :]

       

      Unit: desktop

      Card: MSI RX 480 GAMING X 8G

      OS: Win 7 64

      Driver: adrenaline 18.5.1

      Display: AG241QX but the drivers describe it as AG241QG4, DP, 2560-1440 (recommended res), 144Hz

      Mobo: Gigabyte GA-B150-D3H, bios rev should be 1.0, F5 version, date 11/02/2015

      CPU: Intel Core i5 6500

      PS: XFX TS 550 PRO (P1-550S-XXB9)

      RAM: Hyper X Fury 2x4Gb (HX421C14FBK2/8)

       

      I will try to update this later with some screenshots of the WattMan readings.

       

      EDIT:

      Some screenshots as promised. Sorry for the lousy paint job and evil polishness of the WM settings :]

       

      WM reading while playing 7 Days to Die

      https://imgur.com/a/iu5hgH5

       

      GPU-Z sensor readings of the same time:

      https://imgur.com/a/FfzSYzl

        • Re: RX 480 fan going crazy
          dstmnd89x

          I've owned the same card but I've always used MSI Afterburner to control the fans. Now, if you want to use Wattman that's fine but you'll have to set the min and max enactment for the fans. Disable the automatic curve and set the min to 800 rpm or so and the target to something lower than 2400, say maybe 1600-1800 or so. As the card heats up, the fans will spin up but no more than your specified limit. If the card gets over 65c that's fine as the thermal limit is much higher and this is a fail safe that's hard-coded into the BIOS of the card.

           

          Different titles place different loads on the card as resources are required, so just fiddle with the manual fan curve until you find an ideal spot.

            • Re: RX 480 fan going crazy
              cimerea

              I did try getting AB. Set the curve manualy, started 7 Days to Die, temps at 54*C (some room to tweek the curve, I know) but the game got choppy. Like the card was skiping frames. Closed AB, started again, game fluid like running water, fan through the roof.

                • Re: RX 480 fan going crazy
                  dstmnd89x

                  Ok, I vaguely remember having a similar occurrence with my card but this was a couple of years ago now. Did you try to reset the Wattman settings and lower the fan target value? I think I may have disabled the automatic fan control altogether and ended up running the fan at around 50% or so when I started a game up but the card was certainly one of the quietest I'd owned at the time.

                   

                  Can you post a screenshot of your current global Wattman settings?

                    • Re: RX 480 fan going crazy
                      cimerea

                      You can more or less see them in the screenshots in the 1st post.

                      Everything is on default. I didn't OC, UV or do anything else cause wattman is known for reseting your work whenever it feels like it.

                        • Re: RX 480 fan going crazy
                          dstmnd89x

                          I wasn't able to get the images to load, likely because of my browser, so my apologies... but I see it now.

                           

                          You need to enable manual fan control and temperature in Global Wattman settings, as it shows it is grayed out. This can be done by clicking the slider under the RPM and temperature gauges, and then click Apply. Set the 'target' temperature to around 40c and the max to 80c; change the fan min speed to 500 rpm and max to 1200 or so; then save and apply.

                           

                          That should totally fix it and make sure to completely remove Afterburner from the computer.

                          1 of 1 people found this helpful
                            • Re: RX 480 fan going crazy
                              cimerea

                              That's a patchwork solution unfortunately.

                              Before I read your answer I lowered target temp to 60 (since that's where that card goes bonkers) and max fan to 1911 (fat fingers and lazy). The card still tried to go faster than that. 1948 rpm was the highest peak wattman recorded.

                              To go with a metaphor - I didn't fix the acceleration on my race car, I've put roadblocks in front of it so it would not go too fast by breaking into them.

                              Something is inherently wrong with the way wattman handles fans in my card and I'd really like to make it stop :\

                              Cause let's say i'll overestimate myself and try to play something outrageously gpu consuming. 1200 rpm will send me straight to bluescreen/blackscreen when card goes over 100*C.

                              Also fans still don't stop after closing the game, so I have to reset wattman to make them. Which means I'd have to load and reset the profile every darn time I want to play one of the troublesome games.

                              That's not how an end user supposed to enjoy his PC...