3 Replies Latest reply on Nov 3, 2018 9:08 AM by sakuramichitsuki

    ASRock Fatal1ty B450 Gaming-ITX/ac, XFR2 and PBO options not present

    ziktak

      Hi all.

       

      I've just paired a Ryzen 5 2600, with ASRock Fatal1ty B450 Gaming-ITX/ac motherboard and 16GB(2x8) of 3200Mhz RAM (G.Skill F4-3200C16D-16GVKB).

      Although RAM was not on QVL list, they worked from first moment through XMP profile.

       

      System runs alright, but I cannot find the option for the XFR Enhancement in the BIOS menu. It should be there, but it's not!

      Also, when I run Ryzen Master and move the mouse pointer over Precision Boost Overdrive option a label that says "Future feature in development" pops up...

       

      After some hassle, I've contacted ASRock support. They verified that the option should be there. I've sent them some screenshots showing that it was not present in my BIOS menu where it should be and they suggested a CMOS clear. Did it, but the option still doesn't show up... So, they're still on it and I'm waiting...

       

      I have the latest chipset drivers from AMD and the latest BIOS firmware installed.

      Also, tried both with single and double sticks of RAM, but nothing too...

       

      Has anyone had same experience or knowledge about this?

      Thanks.