6 Replies Latest reply on Nov 8, 2018 1:03 PM by pokester

    Netflix 4k UHD on Athlon 200GE

    core2udo

      Hello everyone,

      i upgraded my HTPC to an AMD Athlon 200GE on a AsRock B450 ITX Board.

       

      Unfortunately Netflix 4K UHD is not working neither with the Windows App nor in the Edge browser.

      Analog to: NETFLIX UHD Stops working after update to 18.9.2

       

      My Setup is:

      Panasonic CXW685 TV

      Hardware (see above)

      Denon AVR-X1300H

       

      HDCP is supported and was tested with by the Cyberlink Blu-Ray Test Tool.

       

      I tested different cables and drivers (18.7.1 and 18.10.1), but dont get it to run.

      YouTube and Media Player Classic plays 4k fine, my Xbox One X is also displaying 4k, so there must be a driver issue.

       

      I've read that Playready 3.0 is not implemented in the driver yet, on some pages I read that it shoud be by Driver Version 18.4.1.

      Whats the status here? Is or is it not supported in the drivers yet? Would be good to know and spares further diagnosis.

       

      Thanks and cheers

      Karl

        • Re: Netflix 4k UHD on Athlon 200GE
          elstaci

          in the thread that you linked did you see the comment from the User concerning the Bug in Windows APP using Netflix:

           

          Re: NETFLIX UHD Stops working after update to 18.9.2

          fxv300

          After a long chat with Netflix on a chat line they responded thus to the Netflix Windows App (Not Edge). Edge is being shut down for 4K by CiscoVideoGuard which can be turned off.  ANyway this is what Netflix said re Windows App:

           

          Alright, as reviewed by our technical research team they found a bug inside the Windows 10 app that is triggering this 4k to be disabled and they are currently working on it. Though we were not given any estimated time but rest assured that this is being worked on.

           

          At least they have acknowledge they have a problem which is a start.

           

          Hope that helps.

           

          See if this thread from Microsoft Forum where Netflix UHD is not working in Windows APP nor Edge browser: 4k Netflix is unable to run on Edge, as well as Windows 10 app. Completely freezes - Microsoft Edge Development

           

          According to the User he was able to "Fix" the problem by resetting Windows:

          leon l. Jul 25, 2018

          Hi, just an update, i managed to fix the issue! But i had to reset my PC through the Windows settings menu. It was a huge hassle, but both Microsoft Edge and the Windows 10 Netflix app works now, and displays 4K.

          Whatever the problem was, resetting the PC fixed it.

          This is the latest AMD Driver for your Athlon APU: Radeon™ Software Adrenalin Edition 18.10.1 Release Notes | AMD

          1 of 1 people found this helpful
            • Re: Netflix 4k UHD on Athlon 200GE
              core2udo

              Thanks for the quick answer, after upgrading the PC I made a fresh Windows installation then the required driver, made an Update to the latest Windows Version and then Netflix. I will give it a try, but resetting the PC can't be the solution and did not clarify if play ready is even in the driver.

                • Re: Netflix 4k UHD on Athlon 200GE
                  hardcoregames™

                  you may want to get a basic video card which can handle 4K better than integrated graphics

                    • Re: Netflix 4k UHD on Athlon 200GE
                      core2udo

                      The problem is not the iGPU of the 200GE, it has a Vega 3 inside and should play all the codecs in hardware.

                       

                      Today I made a new fresh install of windows, installed all the drivers but can't get Netflix to run at 4k.

                       

                      It just shows HD and Dolby Atmos which in my understanding says that cable and receiver seems to support 4k. My TV somehow shows up as generic pnp TV, even it can displays 4k 60hz right now.

                       

                      I don't know if there are any drivers for the Panasonic CXW684 I own or if it's even necessary to have proper installed TV / monitor drivers. But could that be the problem?

                       

                      A discrete graphics card is no option because it don't fit in the itx case.

                        • Re: Netflix 4k UHD on Athlon 200GE
                          hardcoregames™

                          ITX is definitely a tight squeeze which is why I prefer to avoid the small platform

                          • Re: Netflix 4k UHD on Athlon 200GE
                            pokester

                            It so hard to say since it seems like the perfect storm situation to get TV's and Computers latest standards meshing together. But absolutely a huge issue is that when a TV does not say that it conforms to TV specs and only has the generic PNP driver as an option, then yes I would be skeptical what is going on. I would make sure you are asking these same questions to the maker of the TV. I would also be playing around with every setting on that tv as I in the past have been amazed at one little change makes my issue go away from the TV side and had nothing to do with my pc hardware and drivers.