AnsweredAssumed Answered

unable to install adrenaline drivers

Question asked by tempash on Oct 10, 2018
Latest reply on Oct 23, 2018 by tempash

I was running Adrenalin Edition 18.9.2 Optional previously fine. Then during what I think was a Windows update (wasn't at my computer to see) the update caused some issues and I got the black screen. Tried few things but couldn't get back up and running so went through a clean Windows 10 Home install and followed guidance found on these support forums ie:

- clean windows install (made sure I was fully updated)

- used AMD uninstaller + DDU (both in safe mode) to make sure no AMD drivers/software remained; also deleted C: AMD folder

- ensured in Bios the my AMD card / PCIe was Primary

- tried installing Adrenaline 18.9.3 (with internet, firewall, AV all disconnected) and the software hangs, freezes the computer (also tried with 18.9.2 which used to work for me; 18.51; and an older 17.12.2 version - none of which could install)

 

- repeated the cleaning in safe mode w/ both AMD uninstaller + DDU; deleted C:\AMD folder

- tried installing Adrenaline software in safe mode; also tried disabling Device Driver Signing in normal mode and safe mode and still the installation hangs

 

- repeated the cleaning in safe mode w/ both AMD uninstaller + DDU; deleted C:\AMD folder

- tried manually installing just the driver using Device Manager and pointing to the driver under C:\AMD\Package\Drivers\Display.. not sure it installed the driver but when I try to install the full software it hangs again

 

Oct 11th tried the following:

- tried installing the newest Adrenalin Edition 18.10.1 Optional after clean uninstall, no internet and virus & firewall exited - still same thing.. starts to install and then hangs the computer

- also updated the iGPU Intel HD 4000 just in case to 10.18.10.5059 and after that the AMD drivers - hangs

- disabled Secure Boot in the bios and tried installing with Driver Signature Enforcement disabled - hangs

 

Right now I've pulled my AMD card and running just on the iGPU Intel HD 4000. I'm also worried that if I get a different newer card I may run into similar issue. So hoping I can get some advice as to other things I can try.

 

Here are my specs:

MSI R7870 Twin Frozr 2GD5/OC

Windows 10 Pro 64bit, 10.0.17134 Build 17134 (was on Windows 10 Home but upgraded)

Driver version installed: can’t install

BenQ GW2760S, HDMI to DVI (from monitor to video card), 1920x1080 @60Hz

Asus P8Z77-V LK, Bios Version 1402 (updated today from 0812 and same issue)

Intel Core i5-3570K CPU 3.40Ghz

OCZ StealthXStream2, OCZ700SXS2, 700W

RAM: 16GB

Outcomes