0 Replies Latest reply on Oct 11, 2018 11:25 AM by vitamuse

    Claim Reward failing with Error- A qualifying AMD product was not detected in your system - SOLVED

    vitamuse

      I just bought the Newegg deal of a RX 580 that comes with the 3 free games via AMD Reward. I had my old driver installed for my r9 270x and then I did a clean uninstall of the driver and installed the new RX 580 and updated it. I am getting this message when I try to claim my Reward

       

      A qualifying AMD product was not detected in your system. Please install the qualifying AMD product and try again. Qualifying Product(s):

      • AMD Radeon RX Vega
      • AMD Radeon RX 580
      • AMD Radeon RX 570

       

      I submitted a support ticket, but I am wondering if anybody has any suggestions or any success on this? Thank you.

       

      Edit SOLVED:

       

      I found a solution on reddit that worked for me. For me hardware acceleration on chrome turned on fixed it. Credit to reddit user u/Delite41384

       

      Got a reply, posting here in case other people run into the issue:

      "This promotion requires you to have your AMD RX580, AMD 570 or Vega gpu installed and set as your default graphics card before you attempt to validate your coupon code.

      Please see our terms and conditions on amdrewards.com for more information.

      As long as your web browser can be set to use the GPU to render its interface your new AMD GPU should get detected on our system. This does not always work on mutli GPU systems.

      Below are a list alternative options:

      Option 1: Try a different web browser

      Some browser are pre-configured to use something called Hardware Acceleration.


      Option 2: Try Google Chrome with Hardware Acceleration Turned On

      Here is a link to check and activate the hardware acceleration on Google Chrome

      "How to Turn Hardware Acceleration On and Off in Chrome" https://www.lifewire.com/hardware-acceleration-in-chrome-4125122


      Option 3: Laptop Users

      Here a link to a source with some guidelines about how to set your new AMD GPU as your default graphics card.

      “Switchable Graphics Help” https://support.amd.com/en-us/kb-articles/Pages/DH-017.aspx"

      Turned on hardware acceleration, didn't work.

      I then tried Firefox (I typically use chrome) no luck, then I tried Internet explorer to no avail, then tried Edge and that worked.