4 Replies Latest reply on Oct 5, 2018 3:23 PM by cottonbloom

    I'm getting an error message that my AMD Catalyst Driver is outdated.

    cottonbloom

      It says I have AMD Radeon HD 8570D ver. 13.152.1.1000 and suggests I update. My computer says there are no updates however I downloaded the latest 17.x.x.x update from the website. It says it's installed but my computer hasn't replaced it with the old version. Help?