19 Replies Latest reply on Oct 17, 2018 7:01 AM by hellthrasher

    VEGA 64 + XG 2730 + Freesync = Random Black Screens

    zboard

      Hello all. I've been living with this problem for 2 months. Here my specs:

      Ryzen 1700x @ 3.9Ghz/1.875v | SAPPHIRE VEGA 64 NITRO Undervolted and with last BIOS | ASRock x370 Taichi Bios P3.30 | Corsair Vengeance 2x8 Gb @ 2933 Mhz | EVGA G3 650W Gold | Samsung EVO 950 250 Gb | Viewsonic XG2730 via DP, lastest firmware and drivers properly installed and a Soundblaster Z, also properly installed.

       

      The problem consists in a Black Screen, when gaming only by now, that lasts for 2-3 seconds and nothing crashes or monitor loses signal or power. It happens apparently randomly, but i can easy trigger it in Guild Wars (2005). The problem, as far as i've tested, only occurs when i enable Freesync. Already had 48h or more of gaming without a single black screen with freesync disabled, so i tie it to freesync. I tried various drivers, reinstalling windows 10, stock GPU, Bought new DP cable which is VESA certified,Changed GPU to the other PCI 3.0 x16 port, Override DP cable voltage to 0, 1 and 2 (Radeon Display settings), checked that monitor is using DP 1.2, enabling/disabling GPU Scaling, changing color depth to 6, full panel instead preserve aspect ratio..... nothing worked, i keep getting the random black screens so i come here to ask people if is just a bad monitor/gpu or is just bad drivers/windows 10 messing things up. I repeat, disabling Freesync solves the Black Screens, but its pointless having this monitor then. Already contacted with Viewsonic support and they started with the typical: are you using latest drivers, are you using 144 hz... so they are not being helpful at all. Already did read a lot of posts about this, some of them solved the issue, but some others didnt.

       

      I'd like people with this issue to post here their specs and problem so maybe we can know whats going on.