1 Reply Latest reply on Oct 3, 2018 8:01 AM by marka67

    Device Manager Code 43 RX 470 4GB

    marka67

      I seem to be unable to install an RX 470 into my computer. When first inserted it comes up saying its using the built-in basic device driver, CCC (or whatever its called these days) says it installs fine but when restarted, it's listed in device manager as Radeon (TM) RX 470 but it gives code 43 saying Windows has disabled it. I've used DDU in safe mode multiple times, I've tried updating it via Windows Update to which sometimes it updates and I still get the code 43 message and sometimes it fails. I've reseated the card twice, updated all other drivers, tried installing it with Driverpack Solutions, tried AMD's own driver remover. I've tried the Windows troubleshooter, I've tried the FSCFix that I've read about whilst trying to get the thing to work all to no avail.

       

      The card I was using was a Sapphire Radeon 7850 which worked fine, I uninstalled it using the DDU before installing the new card.

       

      PC Specs

       

      OS: Windows 10 64 Bit fully up to date

      CPU: AMD Ryzen 1600x

      Mobo: MSI B350 Mortar

      RAM: Crucial 8GB

      PSU: Gigabyte B700H

      GPU: MSI RX 470 4GB

        • Re: Device Manager Code 43 RX 470 4GB
          marka67

          Touch wood I fixed it! I bought it off Amazon Marketplace and it looks like the previous owner had either flashed the wrong BIOS onto it or had flashed it to use for mining. I flashed it to a BIOS that matched all but the last 4 digits of my serial number (as per the instructions) and Windows has finally recognized it and I'm getting 1600FPS in Video Card Stability Test instead of the 20FPS I have been getting for the last 4 hours!