4 Replies Latest reply on Sep 30, 2018 8:18 AM by elstaci

    New RX580 8Gb Golden not running games

    tezlad

      Hi all.

      I recently built a new pc. Everything was running fine, steam games were ok, managed to play Scum for a good few hours on high settings with no problem , even a marked improvement over my last build. Installed Star Control: Origins (which i got free from AMD with the purchase of the card) and played for a few hours. Game crashed , had to hard reset and now no games work. Get to title screen then hangs and quits. Searched the net for people with similar problems and there are a few. Spent 3 days trying everything i could find/think of to resolve this issue but no joy. Pulled the card and tried in a different rig and getting the same results. D3D device not responding.

       

      Current build:

      Windows 10 Pro

      AMD Ryzen 5 1600 6 core

      RX 580 8GB Red Devil Golden

      16GB Corsair Vengeance DDR4 (2x8GB)

      MSI X470 Gaming Plus

      2x25" BenQ panels

      1TB WD blue

      1TB Seagate SSHD

      EVGA 600w PSU

      NO OC,  stock clocks on all.

       

      Tried many fixes found on the net, also clean installs of drivers using DDU safe mode, DSIM Scannow, Tdlr , Reinstalled games and eventually Win10. Tried stress tests/benchmark and crashed Kombustor. DX reinstall. MS Visual C++ redo etc.

       

      Eventually pulled the card and put in a spare 1050Ti and i have no problems at all.

       

      I would also like to add that i have been building AMD/ATI PC's for over 25 years and i have never had this much trouble from one of your cards. Looking through the net and i was surprised to see so many having similar trouble with the 580. This has knocked my confidence in your components.

       

      Thanks in advance for any help.

        • Re: New RX580 8Gb Golden not running games
          elstaci

          Its possible that some parameter on the RX 580 got changed or your GPU vBIOS got corrupted.

           

          You can try to use AMD Wattman to try and reset the GPU card back to "Default".

           

          If not you can try and install Powercolor's AMD GPU Driver (PowerColor 2017) and see if it puts the GPU card back to "Default" settings. If it does and it starts working again, then you can update the AMD Driver again and then use AMD Wattman to configure your GPU Card.

           

          If you are using a 3rd party GPU controller like MSI Afterburner or Trixx or similar software, uninstall it first. But before you uninstall the software make sure you hit the windows to "Restore Default" settings on your GPU Card.

           

          In a worse case scenario (last resort) you may need to reflash the RX 580 vBIOS again to get it back to "Default" settings. You can download the vBIOS from here: VGA Bios Collection | TechPowerUp . or go to Powercolor and see if they have the vBIOS to download for your GPU Card.

           

           

          PowercolorRX 580 8 GB
          Red Devil

           

          2017-03-31 01:51:00015.050.000.001.000000PCI-E1355 / 2000GDDR5Download | Details
          PowercolorRX 580 8 GB

          Red Devil

          2017-04-05 06:12:00015.050.000.001.000000PCI-E1380 / 2000GDDR5Download | Details
          PowercolorRX 580 8 GB

          Red Devil

          2017-04-05 06:12:00015.050.000.001.000000PCI-E1380 / 2000GDDR5Download | Details
          PowercolorRX 580 8 GB

          Red Dragon

          2017-03-30 22:57:00015.050.000.001.000000PCI-E1350 / 2000GDDR5Download | Details
          PowercolorRX 580 4 GB

          Red Dragon

          2017-04-17 22:30:00015.050.000.001.000000PCI-E1350 / 1750GDDR5Download | Details
          PowercolorRX 580 8 GB

          Red Dragon

          2017-12-11 03:09:00015.050.002.001.000000PCI-E1350 / 2000GDDR5Download | Details

           

          Sep 25th, 2018 09:27 EDT change timezone

          1 of 1 people found this helpful