AnsweredAssumed Answered

New to Crossfire, second GPU not working 2 x R9 290x

Question asked by dickydck on Sep 18, 2018
Latest reply on Sep 19, 2018 by dickydck

Hello all, I've scoured the forums here and the internet and have tried a few things to no avail, here is my specs and forgive me if I forget something but I will try to be as thorough as possible. I am having that issue where no matter what I do I can only get one card to actually show any activity, well the second one jumps up to 4% every once in a blue moon.

 

Form Factor

Desktop Mid ATX

Motherboard

MSI X99A Raider

BIOS version P.30

Operating System

Windows 10 Professional x64

Version 1803 (OS Build 17134.284)

10.0.17134 N/A Build 17134

Processor

Intel Core i7-6800K

RAM

32GB EVGA 1600 (I think)

PSU

EVGA 850G2 (850 Watts)

AMD Radeon Version

Adrenalin 18.9.1

GPUs

2 x Sapphire R9 290x

 

 

So far I have tried the following, using FFXIV Benchmark tool as the test reference, in full screen, and there is a Crossfire profile for it.

 

1. Taken the cards out and re-seated

2. Verified each card works on it own by itself

3. Verified each card works in either slot by itself

4. Verified in the software, the Crossfire option is there and enabled

5. Frame Pacing is turned off

6. Tried using DDU for clean driver installs and such

7. Verified in GPUZ that both my PCI-E Slots are running in x16 mode

8. Disabled ULPS in Registry and made sure it is disabled in Afterburner.

9. Verified with Sapphire support that the new card I got (matching) would be fine on a different firmware version.

 

 

any other ideas are welcome and appreciated. I thank you all in advance, and if I left out any important information please let me know.

Outcomes