11 Replies Latest reply on Sep 11, 2018 12:58 AM by amdmatt

    OpenCL for HD 6850?

    spinblade

      I have downloaded the video editing software DaVinci Resolve. Upon starting the software, I immediately get an error message that this software can't find any OpenCL-capable graphic cards. I have an AMD Radeon HD 6850. As far as I can tell from the Geeks3D viewer, there does seem to be some kind of OpenCL support -- unless I'm reading the output wrong. Please see a screenshot here https://ibb.co/kHyiZp of both the software's error message and Geeks3D output. Is there OpenCL support for the HD 6850 or am I misreading the Geeks3D OpenCL info there, and what should I do about this problem?

       

      I am on Windows 10 64 bit and have Radeon Crimson 16.2.1 installed.

       

      Would appreciate any help. Thanks.

        • Re: OpenCL for HD 6850?
          kingfish

          Multiple posts are against forum rules

          HD 6850 not recognized by software

            • This reply has been hidden. This can happen if the message has been hidden by a moderator, or has been reported as abusive.
              • Re: OpenCL for HD 6850?
                amdmatt

                I have locked the other thread, please use this one going forward.

                  • Re: OpenCL for HD 6850?
                    spinblade

                    Great stuff. Do you think you could perhaps help with the issue I'm having here? That would be appreciated, amdmatt.

                      • Re: OpenCL for HD 6850?
                        ray_m

                        I'm pretty sure that the HD6850 does not meet the requirements of Da Vinci Resolve, apart from the fact that it probably required updated display drivers, which are not available for this product which has long been moved to legacy status.


                        What version of Da Vinci are you trying to run ?

                          • Re: OpenCL for HD 6850?
                            spinblade

                            Hi, ray_m. Thanks. I'm trying to run DaVinci 15. So when you say it requires updated display drivers, what does that mean? I'm currently running Radeon Crimson 16.2.1. Is there something else I should try in that regard for OpenCL support? Crimson gives me the following info:

                             

                            Radeon Settings Version - 2016.0226.1531.27895

                            Driver Packaging Version - 15.301.1901-160226a-318062E

                            Provider - Advanced Micro Devices, Inc.

                            2D Driver Version - 8.1.1.1533

                            Direct3D® Version - 9.14.10.1171

                            OpenGL® Version - 6.14.10.13417

                            OpenCL™ Version - 2.0.4.0

                            AMD Mantle Version - 9.1.10.99

                            AMD Mantle API Version - Not Available

                            AMD Audio Driver Version - 10.0.0.2

                             

                            So it's showing OpenCL there, but DaVinci doesn't seem to recognize it. Is OpenCL perhaps not loaded properly or something? I also notice that Geeks3D shows OpenCL 1.2 and Crimson shows OpenCL 2.0, which is strange. But it seems like OpenCL is there, so it's odd DaVinci doesn't recognize it. Performance issues that I might face if I ever actually get DaVinci started aside (which is a bridge I'll cross if I get to it), it's confusing as to why DaVinci doesn't think my card has OpenCL support when it seems like it has. Both Geeks3D and Crimson show OpenCL. So I wonder what's happening there.